[Solved] Errors when building to Android

iroosma

  • *
  • Posts: 97
I have been able to successfully build to ios for quite a while.  I am now trying to build to Android and I keep getting the following errors.  Log files also attached.  Thanks so much for anyone who can help.

2018-04-13 20:38:33,158 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [haxelib] arm-linux-androideabi-g++ -Iinclude --sysroot=/Users/iroosma/stencylworks/android-sdk/android-ndk-r16b/platforms/android-9/arch-arm -I/Users/iroosma/stencylworks/android-sdk/android-ndk-r16b/sources/cxx-stl/gnu-libstdc++/4.9/include -I/Users/iroosma/stencylworks/android-sdk/android-ndk-r16b/sources/cxx-stl/gnu-libstdc++/4.9/libs/armeabi/include -DHXCPP_ARMV7 -DHXCPP_VISIT_ALLOCS -DHXCPP_API_LEVEL=331 -I/Applications/Stencyl-full/plaf/haxe/lib/hxcpp/hxcpp/include -Iinclude -fpic -fvisibility=hidden -ffunction-sections -funwind-tables -fstack-protector -fno-short-enums -Wno-overflow "-D_LINUX_STDDEF_H " -Wno-psabi -DHXCPP_CPP11 -DHXCPP_ARMV7 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp -fomit-frame-pointer -fexceptions -fno-strict-aliasing -finline-limit=10000 -DANDROID=ANDROID -DHX_ANDROID -DHXCPP_ANDROID_PLATFORM=9 -Wa,--noexecstack -O2 -DNDEBUG -c -Wno-invalid-offsetof -frtti -std=c++11 -o "/Users/iroosma/stencylworks/games-generated/BallerCoaster v21/Export/android/obj/obj/android-v7/__pch/haxe/hxcpp.h.gch" /Applications/Stencyl-full/plaf/haxe/lib/hxcpp/hxcpp/include/hxcpp.h
2018-04-13 20:38:33,168 DEBUG [pool-1-thread-1] stencyl.sw.util.Util: Process 'haxelib' exited with code: 1
2018-04-13 20:38:33,169 ERROR [pool-1-thread-1] stencyl.sw.app.tasks.buildgame.GameBuilder: Failed: Running Android. (Return code: 1)
2018-04-13 20:38:33,169 ERROR [pool-1-thread-1] stencyl.sw.util.dg.MessageDialog: Encountered errors while building your game.: Check your logs and post them to the forums.  - Please describe what you have been doing. Be as specific as possible.
2018-04-13 20:39:01,270 DEBUG [AWT-EventQueue-0] stencyl.sw.app.App: Action: Generate Logs
2018-04-13 20:39:01,272 DEBUG [pool-1-thread-1] stencyl.sw.util.FileHelper: Matching (non-hidden) files within /Users/iroosma/stencylworks/logs: [/Users/iroosma/stencylworks/logs/2018-04-13_20-37-30.log]

« Last Edit: April 14, 2018, 03:01:42 pm by iroosma »

rob1221

  • *
  • Posts: 9244
Try a lower NDK version such as 15 or 14 as 16b doesn't seem to work well with Stencyl right now.

iroosma

  • *
  • Posts: 97
Thanks so much.  I installed NDK 15c and it worked on the first try!