Exporting Game to Xcode Errors

retroed

  • *
  • Posts: 34
I'm getting these errors when I open the exported .xcodeproj file in Xcode. I am opening Xcode 9 from within Stencyl 3.5

Ld /Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Intermediates.noindex/Metronome\ Swipe.build/Debug-iphoneos/Metronome\ Swipe.build/Objects-normal/armv7/Metronome\ Swipe normal armv7
    cd "/Users/sharnyyoko/Desktop/Metronome Swipe/Export/ios"
    export IPHONEOS_DEPLOYMENT_TARGET=10
    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch armv7 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk -L/Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Products/Debug-iphoneos -L/Users/sharnyyoko/Desktop/Metronome\ Swipe/Export/ios/Metronome\ Swipe/lib/armv7-debug -L/Users/sharnyyoko/Desktop/Metronome\ Swipe/Export/ios/Metronome\ Swipe/lib/armv7 -F/Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Products/Debug-iphoneos -F/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk/System/Library/Frameworks -filelist /Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Intermediates.noindex/Metronome\ Swipe.build/Debug-iphoneos/Metronome\ Swipe.build/Objects-normal/armv7/Metronome\ Swipe.LinkFileList -miphoneos-version-min=10 -dead_strip -Xlinker -object_path_lto -Xlinker /Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Intermediates.noindex/Metronome\ Swipe.build/Debug-iphoneos/Metronome\ Swipe.build/Objects-normal/armv7/Metronome\ Swipe_lto.o -Xlinker -export_dynamic -Xlinker -no_deduplicate -framework GameController -framework CoreText -framework UIKit -framework OpenAL -framework OpenGLES -framework QuartzCore -framework CoreAudio -framework CoreGraphics -framework AudioToolbox -framework AVFoundation -framework Foundation -framework CoreMotion -framework MediaPlayer -framework GameKit -framework SystemConfiguration -framework StoreKit -Xlinker -dependency_info -Xlinker /Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Intermediates.noindex/Metronome\ Swipe.build/Debug-iphoneos/Metronome\ Swipe.build/Objects-normal/armv7/Metronome\ Swipe_dependency_info.dat -o /Users/sharnyyoko/Library/Developer/Xcode/DerivedData/Metronome_Swipe-awtlegawxeibzeduaswpwjzryytl/Build/Intermediates.noindex/Metronome\ Swipe.build/Debug-iphoneos/Metronome\ Swipe.build/Objects-normal/armv7/Metronome\ Swipe

ld: entry point (_main) undefined. for architecture armv7
clang: error: linker command failed with exit code 1 (use -v to see invocation)

retroed

  • *
  • Posts: 34
Btw, I'm getting these errors after deleting the "Haxe" target, cleaning and attempting to archive again. I'm also getting some warnings (see screenshot), which seem to be related to icon and splash screen dimensions for certain scalings.

designpeg

  • *
  • Posts: 578
That last mach-O error - are you trying to run your game in the simulator, or an actual device from xcode?

I get the same error  when I try to use the simulator, but xcode will compile and run fine on my actual devices.

retroed

  • *
  • Posts: 34
Btw, I'm getting these errors after deleting the "Haxe" target, cleaning and attempting to archive again. I'm also getting some warnings (see screenshot), which seem to be related to icon and splash screen dimensions for certain scalings.

These errors are from attempting to "Archive" the game so I can export the .ipa, I haven't tried to run the simulators from Xcode,  only from Stencyl. I'll try that later today and see if I get the same errors. Either way I am hoping to submit the app ASAP so if anyone knows how to resolve these errors that would be great.

designpeg

  • *
  • Posts: 578
Make sure you set the 1024 x 1024px icon in xcode - Apple will reject your app if you don't include this. Not sure about the other missing icons.