Stencyl 3.4 or 3.5?

peterson

  • Posts: 3
Hey! Just wondering if I should start using 3.4 or 3.5?

I know I need a license to use 3.5 but I still would like to know the difference at this current time. I'm not really new to stencyl as I've used it to make games before so I don't really need to start with 3.4 to get familiar with it. I just want to start working on a game using the version best suited for uploading to the play/app store in a couple months from now.

Thanks!  :)

ViniciusAlves

  • *
  • Posts: 38
I would like to know the community's thoughts on this too.

colburt187

  • *
  • Posts: 2230
The main difference is that 3.5 supports Xcode 9 which is needed to support the iPhone X. 3.5 scales correctly on the iPhone X and also has the block "Running on iPhone X".

There is not that much different in terms of building a game in 3.5 compared to 3.4. Most of the time when I open a game i made in 3.4 in 3.5, the only changes I need to make are button placements for the iPhone X.

There may be other differences that im missing, but so far I haven't noticed much else.

merrak

  • *
  • Posts: 2006
3.5 uses the newer OpenFL, but that appears to be more notable for desktop and HTML5 games.

RulezTeam

  • *
  • Posts: 285
With 3.5 you can publish for android with API > 22, with 3.4 no, and Google (in a short time) will require to publish at least with api 26, so...

peterson

  • Posts: 3
So what I'm hearing is 3.4 is fine but start building in 3.5 if I want iphone x support and if I want to avoid issues when publishing to iOS/Android. Also I imagine when updating a game from 3.4 to 3.5 there can be issues in some cases.

Thanks everyone, I appreciate all the replies!