Autoscrolling when set to ZERO goes back to its original position

GameDev408

  • *
  • Posts: 236
Right now, I've coded that when the game is unpaused, the autoscroll for a layer is -10x. It works fine.
Then I coded if the game is paused, autoscroll speed is now 0, 0.
This entirely resets the entire background (I'm using a long background) to its original position.

How do I ultimately pause the background instead of resetting it back to where it started?

LIBERADO

  • *
  • Posts: 2575
In the Background editor, set to 0 the Horizontal and Vertical Parallax Factor.
I'm spanish, excuse me for my bad English.
I'm not a private teacher. Please, post your questions in the public forum.

GameDev408

  • *
  • Posts: 236
In the Background editor, set to 0 the Horizontal and Vertical Parallax Factor.

You, my good sir,  are a genius. Thank you!

squeeb

  • Posts: 1348
In the Background editor, set to 0 the Horizontal and Vertical Parallax Factor.

You, my good sir,  are a genius. Thank you!
I keep trying to tell him! 

GameDev408

  • *
  • Posts: 236
In the Background editor, set to 0 the Horizontal and Vertical Parallax Factor.

You, my good sir,  are a genius. Thank you!
I keep trying to tell him! 

Well, sir, I've seen you around the forums too... you're also a muscle genius man.

squeeb

  • Posts: 1348
Haha.. thanks.. i try.. i learned from a lot of these great guys here!  Pm me on discord if i can ever help with anything!

GameDev408

  • *
  • Posts: 236
Haha.. thanks.. i try.. i learned from a lot of these great guys here!  Pm me on discord if i can ever help with anything!

Haha, thanks for the warm gesture mate!
Though, I'm curious, one question, have you sold any games to Y8?