Building games under Archlinux issue

Hey everyone, I'm trying to boot Stencyl on Arch and I've got an issue. I can't build any game and there's always the same issue in the log:

018-07-16 01:43:54,372 INFO  [Thread-18] stencyl.sw.util.StreamGobbler: [haxelib] Called from /usr/lib/haxe/std/neko/_std/EReg.hx line 200
2018-07-16 01:43:54,373 INFO  [Thread-18] stencyl.sw.util.StreamGobbler: [haxelib] Uncaught exception - load.c(237) : Failed to load library : /home/jan/.local/share/stencyl/plaf/neko-linux/regexp.ndll (libpcre.so.3: cannot open shared object file: No such file or directory)

As I understand, regexp is the part of haxelib, but installing the haxe package didn't give any results. Is there any thoughts, how to fix that?

merrak

  • *
  • Posts: 2080
I think I ran into this issue back when I used Arch (moved to Ubuntu now). I don't remember how I fixed it--probably had to find the library in its package and install it. See if this helps: https://bbs.archlinux.org/viewtopic.php?id=67869

Quote
The pkgfile tool is your friend. wink It is in the community/pkgtools package.
Did you install these packages?
bp:~$ pkgfile libpcre.so
core/pcre
bp:~$ pkgfile libssl.so
community/apache13
community/lib32-openssl
core/openssl
bp:~$ pkgfile libmysqlclient.so
extra/libmysqlclient