Android doesn't compile

DCameron

  • Posts: 63
My Android game doesn't compile, I created a test game with a blank screen, same problem. Abridged logs attached :
Artist for hire: http://community.stencyl.com/index.php/topic,49739.0.html

Play my games on Kongregate:                                     Get updates on my Patreon page:

TheIndieStation

  • *
  • Posts: 2257
What android version are you using in stencyl?

DCameron

  • Posts: 63
Minimum: API 9 - 2.3 (Gingerbread)
Target: API 26 - 8.0.0 (Oreo)
Artist for hire: http://community.stencyl.com/index.php/topic,49739.0.html

Play my games on Kongregate:                                     Get updates on my Patreon page:

TheIndieStation

  • *
  • Posts: 2257
And what sdk etc version?

DCameron

  • Posts: 63
NDK: android-ndk-r15c
JDK: jdk1.8.0_181
Stencyl 3.5 Beta 2
Artist for hire: http://community.stencyl.com/index.php/topic,49739.0.html

Play my games on Kongregate:                                     Get updates on my Patreon page:

TheIndieStation

  • *
  • Posts: 2257
Try setting your target to 9 as well. Fixed it for me.

rob1221

  • *
  • Posts: 9430
It's an issue with some imports added to the Native class on July 15 but I don't know why only some devs are affected by it.  Reverting that change would break the keyboard again but I may need to do that if another solution isn't found soon.

If you want to continue right now you can replace plaf\haxe\extensions\native\dependencies\native\src\com\androidnative\Native.java with the attached one, although it will undo some fixes for the Android keyboard.

Try setting your target to 9 as well. Fixed it for me.
Google now requires 26+ for new uploads.

« Last Edit: August 08, 2018, 10:08:22 am by rob1221 »

DevX81

  • *
  • Posts: 1
Stumbled upon this thread (glad I did). Had the same error as the original poster and your native.java fixed it. I did not have this issue in 3.5, but I did in 4.0. I did have to use the updated sw.jar file to first even get the android SDK/NDK to download. Did many project cleans, reinstalled the SDK/NDK as well as most recent Java SDK. Only this fix helped, app compiled fine and pushed out to my android device with no issues afterwards. Let me know if you want any further info on system setup/versions/etc.

rob1221

  • *
  • Posts: 9430
I recently found out that this error can be caused by installing Stencyl over an existing install which you should never do.  Always install new Stencyl versions into an empty folder (clean install).

svintaj

  • *
  • Posts: 298
I recently found out that this error can be caused by installing Stencyl over an existing install which you should never do.  Always install new Stencyl versions into an empty folder (clean install).
(Hm, I might have this problem as well now, I'm just going from 3.5 to 4.0... ) Do I also need to delete the stencylworks-folder to have a 'clean install of Stencyl', or should I avoid deleting the stencylworks-folder?  I know have all my games in that stencylworks folder and I have made an backup of the games, but there is also all extensions, old preferences e.t.c.  Shall I remove everything  there except my games?  :-\

Justin

  • *
  • Posts: 4336
Don't touch stencylworks. You can copy it to back it up if you want, but you don't need to delete it.

You also don't need to remove your old copy of Stencyl if you don't want to.

All you need to do is make sure that you're not installing your new copy of Stencyl somewhere where you have an existing Stencyl version.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)