cc1plus.exe: out of memory

Lavaflame2

  • *
  • Posts: 1
I've been successfully running my game on my android device for 2 - 3 months now, and all of a sudden I keep getting this "out of memory" issue. It only happens with my most recent version of my game (file size ~ 30MB) -- when I try to run my OLD versions (over 1 week ago), they all still work, despite them being larger file sizes ( ~ 60 MB, newer one is half the size because I had several LARGE images that I no longer use).

My question is, what the hell should I look for? What might I have done to my game to cause this?

(Possible Fixes that I have tried that **DONT WORK**)
I use the custom .bat file to start Stencyl (I've tried using the 2GB, 3GB, 4GB and 6GB ones, all to no avail), my computer has 8GB of memory (usually has 4GB available at any given time).
I've also tried NOT using the .bat, which also didn't work.
I even sat and watched my Resource monitor and saw that the ccplus1 and java tasks were never taking up more than ~1GB of memory, and I **always** had 1 or 2GB of available memory, so I REALLY shouldnt be running out of memory...
I purchased the $200 studio version to see if publishing the game would work, but ran into the same problem.

I'd love to hear any and all suggestions, I'm really stumped on this one...


2018-09-13 21:30:39,892 ERROR [Thread-22] stencyl.sw.util.dg.MessageDialog: Error: Compilation Error - There was an error compiling your game. Check your logs for details.
2018-09-13 21:30:43,526 ERROR [Thread-22] stencyl.sw.util.StreamGobbler: [haxelib.exe] Error in building thread
2018-09-13 21:30:43,527 INFO  [Thread-22] stencyl.sw.util.StreamGobbler: [haxelib.exe] arm-linux-androideabi-g++ -Iinclude --sysroot=C:\Users\mhawk\AppData\Roaming\Stencyl\stencylworks\android-sdk/android-ndk-r7b//platforms/android-9/arch-arm -IC:\Users\mhawk\AppData\Roaming\Stencyl\stencylworks\android-sdk/android-ndk-r7b//sources/cxx-stl/gnu-libstdc++/libs/armeabi/include -IC:\Users\mhawk\AppData\Roaming\Stencyl\stencylworks\android-sdk/android-ndk-r7b//sources/cxx-stl/gnu-libstdc++/include -DHXCPP_VISIT_ALLOCS -DHXCPP_API_LEVEL=321 "-IC:/Program Files (x86)/Stencyl/plaf/haxe/lib/hxcpp/hxcpp/include" -Iinclude -fpic -fvisibility=hidden -ffunction-sections -funwind-tables -fstack-protector -fno-short-enums "-D_LINUX_STDDEF_H " -Wno-psabi -D__ARM_ARCH_5__ -D__ARM_ARCH_5T__ -D__ARM_ARCH_5E__ -D__ARM_ARCH_5TE__ -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp -fomit-frame-pointer -fexceptions -fno-strict-aliasing -finline-limit=10000 -DANDROID=ANDROID -DHX_ANDROID -DHXCPP_ANDROID_PLATFORM=14 -Wa,--noexecstack -O2 -DNDEBUG -c -x c++ -Wno-invalid-offsetof -frtti ./src/scripts/MyAssets.cpp -oC:/Users/mhawk/AppData/Roaming/Stencyl/stencylworks/games-generated/liftingsimulator/Export/android/obj/obj/android-v7/717949eb_MyAssets.obj
2018-09-13 21:30:43,528 INFO  [Thread-22] stencyl.sw.util.StreamGobbler: [haxelib.exe] Error:
2018-09-13 21:30:43,530 ERROR [Thread-22] stencyl.sw.util.dg.MessageDialog: Encountered errors while building your game.: Check your logs and post them to the forums.  - Please describe what you have been doing. Be as specific as possible. Not enough memory to complete this build. Close some apps or reboot, then try again. (cc1plus.exe: out of memory)
2018-09-13 21:30:44,200 DEBUG [pool-1-thread-3] stencyl.sw.util.Util: Process 'haxelib.exe' exited with code: 1
2018-09-13 21:30:45,041 ERROR [Thread-22] stencyl.sw.util.StreamGobbler: [haxelib.exe] cc1plus.exe: out of memory allocating 2483488 bytes
2018-09-13 21:30:45,042 ERROR [pool-1-thread-3] stencyl.sw.io.write.resource.HXWriter: Failed: Running Android. (Return code: 1)

here are the Error logs that I think are relevant, might help with any suggestions