Stencyl 4.0.1 runnning windows fps issue?

Behappy859

  • Posts: 45
hello,

I've been doing some testing on 4.0  trying to receive a better fps. I've been  working on this game for awhile back on 3.4.  Figure I would try 4.0 again. So I made a back up. then loaded my game on 4.0. I literally deleted almost every behavior I have. Except for walking.  I have few new scenes ive been testing on. Ive notice if I make a small scene the fps is working great with my tiles. However, when I make a 50x40 scene at 64x64 tile size and add my wall tiles that have collision, if I my pc starts to walk I get a 9 fps on windows not running on flash.  But with stencyl 3.4 the fps is running great even with the tinted screen behaviors. Could this possibly be a error in 4.0.1 update? I don't understand why stencil 4.0 fps is so low even when everything is deleted expect for walking. the Flash I tried works great I might add, but I plan on making the game for console. Any suggestions?

rob1221

  • *
  • Posts: 9421
Could you attach the stripped down project?

Behappy859

  • Posts: 45
Could you attach the stripped down project?

hello,
yes, I would like to, however I do not know what stripped down project means? do you mean upload the game on arcade?

Luyren

  • *
  • Posts: 1670
Open the game you said you removed everything except your walking behavior, go to File > Export game, attach the generated file to your post. Would also be a good idea to generate your logs (Tools > Logs > Generate Logs) and attach that too.
Working.

Behappy859

  • Posts: 45
Open the game you said you removed everything except your walking behavior, go to File > Export game, attach the generated file to your post. Would also be a good idea to generate your logs (Tools > Logs > Generate Logs) and attach that too.

never mind I relaunched stencyl and im now running 60/60 fps (windows). not sure why its working now but thank you.