One of my Scenes stopped working!

CTWitt

  • Posts: 7
Sorry to be Mr. Clueless, but when you say constrain the index and create a warning in the logs, what does that actually mean I should do to accomplish that? Is there something I can do to adjust the index in the scene's xml file? I'd really appreciate any clarification.

rob1221

  • *
  • Posts: 9424
Changing the "order" values all to 0 might at least let you open the scene, but if there are multiple actors on the same layer this error will likely keep happening.  The data saved in the xml files is correct, but the way Stencyl is adding the actors to the layer's list is incorrect.

Behappy859

  • Posts: 51
the same thing is happening to me as well. this game is a back up file from 3.4 onto 4.0.1. the error mainly happens when i place too many actors in the game. will this error soon be fix in a update? Im thinking about starting from scratch and adding my actors again. any help be great.

FMStudioGameDev

  • *
  • Posts: 209
the same thing is happening to me as well. this game is a back up file from 3.4 onto 4.0.1. the error mainly happens when i place too many actors in the game. will this error soon be fix in a update? Im thinking about starting from scratch and adding my actors again. any help be great.
I do not recommend doing it, I did, created a brand new project from scratch but after a whole day of work the error popped up again...
But to be honest, after rob's patch in b10318, I regained access to the broken scenes and so far the error hasn't happened again.

CTWitt

  • Posts: 7
I tried Rob's suggestion as well, and so far it seems to have worked in my case too! Thanks Rob!

Behappy859

  • Posts: 51
the same thing is happening to me as well. this game is a back up file from 3.4 onto 4.0.1. the error mainly happens when i place too many actors in the game. will this error soon be fix in a update? Im thinking about starting from scratch and adding my actors again. any help be great.
I do not recommend doing it, I did, created a brand new project from scratch but after a whole day of work the error popped up again...
But to be honest, after rob's patch in b10318, I regained access to the broken scenes and so far the error hasn't happened again.
thank you very much I was getting ready to da that until I looked on here first.  if you don't mind, is this patch Rob made going to be in a update? or is it something that manually has to be done.

rob1221

  • *
  • Posts: 9424
The fix will be in the next public build, but I don't know when that will be.

Behappy859

  • Posts: 51
The fix will be in the next public build, but I don't know when that will be.
thank you very much. I guess its a fine time to stop procrastinating on making sprites. lol. I do hope the people of stencyl will send people a notification on the new update. looking forward to it.

JeffreyDriver

  • Posts: 2122
It's been about 5 months. Any news on the fixed release?
Current Projects:
The Grand Grimoire Chronicles Episode 1 now on Kongregate!.
I always appreciate useful feedback. Thank you.
www.jeffreydriver.co.uk

demodiabp

  • *
  • Posts: 9
Any update on this?  This bug has corrupted most of my scenes and I need to finish this program.  Is there anyway to get a patch for the issue that was fixed "March 26, 2019 (b10318) Avoided index out of bounds error causing scenes to not open (issue #1518)"?