How to set the API on Android to 26

taulant

  • *
  • Posts: 7
When I upload the APK I get this prompt from the Goole Play Store
Quote
Upload failed
Your app currently targets API level 16 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance. Change your app's target API level to at least 26. Learn how.

Meanwhile Stelncyl doesn't allow selection above API level 22.

I looked in the forum and the recommendation was to set the edit Openfl settings to the line below
Code: [Select]
<android minimum-sdk-version="26" target-sdk-version="26” />
Doing this just throws an error. I am attaching the error log for more information.

I am really disappointed as I just paid $199 to be able to publish my game.  :(

corbanwolf

  • Posts: 161
settings -> mobile -> versions
make sure you have the latest version of stencyl too

taulant

  • *
  • Posts: 7
That is where I was selecting but it is not letting me go higher than 22. I need to have at least API level 26 to be able to upload on the Play Store. See attached image.

Quote
settings -> mobile -> versions
make sure you have the latest version of stencyl too

corbanwolf

  • Posts: 161
Check [manage installed versions] and install newest compilers

Justin

  • *
  • Posts: 4336
Quote
make sure you have the latest version of stencyl too

This is the important part. You cannot use anything higher than 22 with the version of Stencyl you're currently using. When you update, as corban mentions, you'll have a little work to do getting the android sdk set up.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

taulant

  • *
  • Posts: 7
Thanks for your recommendations @Justing & @corbanwolf. Updating to Stencyl 4.0.1 helped. I was able to set the Android API to 26. I am however experiencing new issues during compiling for API version 26. I will open a new thread for that.