What Java JDK should I be using?

grmata

  • Posts: 21
I'm using the latest 12.0.1

I get this error when I try to build for Android.

2019-05-14 22:51:35,963 ERROR [Thread-14] stencyl.sw.util.StreamGobbler: [haxelib.exe] FAILURE: Build failed with an exception.
2019-05-14 22:51:35,964 INFO  [Thread-14] stencyl.sw.util.StreamGobbler: [haxelib.exe] * What went wrong:
2019-05-14 22:51:35,964 INFO  [Thread-14] stencyl.sw.util.StreamGobbler: [haxelib.exe] Could not determine java version from '12.0.1'.


johnjanowskibsc

  • *
  • Posts: 81
Hi. I went through all this a couple of weeks back. You have to stick with JDK 8.

grmata

  • Posts: 21
Hi. I went through all this a couple of weeks back. You have to stick with JDK 8.

Ok, Do you have the exact steps I need to follow to do an Android build?
I've tried different tutorials but I keep getting weird build errors. Like files not being in the right place or missing.
Seems like the build script is off or something.

johnjanowskibsc

  • *
  • Posts: 81
Off the top of the head I just downloaded jdk 8. I didn’t bother uninstalling jdk12. Then i made sure stencyl was pointing at jdk 8 before proceeding. I think I also set the minimum and maximum api to 21 and 26.
Hope this helps?