Publish option not available in Stencyl 4.0.1


  • Posts: 41
I have this problem. I have recently installed Stencyl 4.0.1. The games can be designed and tested with no problem. However the publishing in Flash (as well as other formats) is not available (the option is grayed and can not be clicked). I previously worked on Stencyl 2.2 and Stencyl 3 and never experienced this problem.
Anyone can help?


  • *
  • Posts: 2671
Flash should only be grayed out of you don't have any game open. If it's grayed out with a game open, my only suggestion is to reinstall Stencyl.
My Stencyl resources are available here:
Cutscenes, RPG Elements, Particles, Map System and many more.


  • Posts: 208
You have to be sure that you are logged in on your Stencyl App.


  • Posts: 41
I tried to re-install the software on two different computers (Windows 7 and Windows 10) and the result is the same.
I do not understand what "logged on your Stancyl app" means. Does it mean that Stencyl 4 works only on-line? The software I installed is the free version and not the PRO version, thus flash publishing should be allowed. I tried to install also Stencyl 3.4 and Stencyl 2.2 and both works (flash publishing is allowed).