Game doesn't open [Resolved]

RandomJibberish

  • Posts: 82
I was editing my game last night and it was working fine, but since I quit Stencylworks the game refuses to open. Double clicking on the game or Selecting and clicking open game does nothing, but other games, and an older version of the game from forge, open fine.

Oddly, Stencyl also seems to think I have a game open when I don't - it asks me to save when I quit from the Welcome Centre screen.

My zipped up game folder is here

« Last Edit: April 29, 2011, 07:26:02 pm by Jon »

Jon

  • *
  • Posts: 17529
Your games/Crazy Golf/resources/data.xml file is incomplete.

The easiest way to restore this would be if you had a recent backup and to stick that exact file back in. You may also possibly find it in your sandbox directory.

Another way to get it is to download the SWF for your game and fetch it back using a SWF decompiler.

Last resorts would be to get the version you have on Forge (I think it's too old?) and get it from there or to manually fix this file and probably lose some data (not the images, but how you configured things).

This one comes up every once in a while, and I, for the life of me, have never been able to reproduce it, even if I did crazy things like rapidly clicking save. It could be a legitimate bug, or it could be an illegitimate one (the program was forcibly closed while it was closing or saving).

Jon

  • *
  • Posts: 17529
What I'll do for now is pop up an actual error message in response to this scenario, so anyone who bumps into it in the future knows what it's about.

Jon

  • *
  • Posts: 17529
One other thing that would help greatly is if you could post your logs for today and yesterday as well as recalling whether you ever saw any errors pop up in the console at the time of saving. These, at least, narrow the field down.

RandomJibberish

  • Posts: 82
I pasted in the file from the forge version, which is fairly recent, and it works fine. I have a bit of fixing to do but it isn't too bad.

Unfortunately I don't have my logs, since I reinstalled Stencylworks attempting to fix the issue. If this comes up again I'll be sure to get the logs to you.