HELP!!! PLEASE LOL

2wasted2

  • *
  • Posts: 9
I purchased  Studio so I can export my game, it all worked well... Then I updated to the newest version and now I can not export or even test on my android phone???
Any help is very much appreciated
It says "Failed: Running Android. (return code: 1)

Many Thanks in advance
I have attached logs

Luyren

  • *
  • Posts: 1949
Hit "Clean Project," then open each of your individual scenes, then save the game and try again.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles and many more.
Twitter

2wasted2

  • *
  • Posts: 9
Many Thanks for your reply
I did what you said... but still the same error
Everything worked before I updated to 4.0.2, I compiled a apk etc etc
but as soon as I updated it will not work.
I have attached the new logs incase something else shows
Thank you once again for your help

2wasted2

  • *
  • Posts: 9
Also I should add... it's not just doing it on this game
Even when I just make a black screen and test or compile it throws up the same error
As I said this was after I updated before everything was working fine
Any help is much appreciated
I knew as soon as I paid something would happen  ;) :'(

Luyren

  • *
  • Posts: 1949
The error in your logs now is different than the previous one. You should first test if you can compile on Flash, HTML5 or your desktop platform.

Either way, you are now a subscriber. You should use the most recent private build (which as far as I know has your error fixed), instead of the public one. Just go to the forum's front page and you'll see a link to get the private build.

And if all else fails, reinstall Stencyl, the android tools and all the mobile-related stuff.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles and many more.
Twitter

2wasted2

  • *
  • Posts: 9
Ok thank you
I will try again in the morning.
 ;D

2wasted2

  • *
  • Posts: 9
Good Morning
I have once again tried what you said... uninstalled and reinstalled the newest version
Also I downloaded the Android tools and it still fails to test or build
It does work to test on flash tho
Im really at my wit ends here... been up since 5am lol

Once again I have posted the logs also A screenshot of the android tools incase they are wrong
Many Thanks

Justin

  • *
  • Posts: 4384
See the replies here.

http://community.stencyl.com/index.php/topic,59888.0.html

This hasn't been fixed in the latest private builds yet. It will be within a day or so. The changes are simple enough to make manually that I'd recommend doing so rather than waiting.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

2wasted2

  • *
  • Posts: 9
Yes Justin that worked.
You are a Legend my friend.
Many Thanks
Mike