I can't get Stencyl to test my game.

nla2987

  • Posts: 5
If I hit the "Test Game" button in the right hand corner of the screen, it says, "Check your logs and post them to forums" instead of me testing my game. It wants me to Generate Logs. It was working before, not to mention I was making progress, but I am not sure as what to do from here in order to keep working on my game. I had this issue before, so I started all over. Now I am having this issue again, and I really do not want to start all over once more with a new game file.

Luyren

  • *
  • Posts: 2176
Settings > Advanced > Uncheck all the scales except x1.
Tools > Game > Clean Up Unused Files and Clean Project.
Close your game and close Stencyl.
Reopen everything and test your game. If you get a new error message, generate your logs again and post them.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

nla2987

  • Posts: 5
Settings > Advanced > Uncheck all the scales except x1.
Tools > Game > Clean Up Unused Files and Clean Project.
Close your game and close Stencyl.
Reopen everything and test your game. If you get a new error message, generate your logs again and post them.

It did the same thing. Here is my most recent log.

Luyren

  • *
  • Posts: 2176
Code: [Select]
2020-05-23 11:06:21,653 ERROR [pool-1-thread-1] stencyl.sw.io.GameAssets: Source '/Users/neilandrews/stencylworks/games/The Adventures of Neil and Joshua/resources/48-0.png' does not exist
java.io.FileNotFoundException: Source '/Users/neilandrews/stencylworks/games/The Adventures of Neil and Joshua/resources/48-0.png' does not exist
Tools > Workspace > View Workspace Folder for this Game, navigante to the resources folder, and place there an image file called "48-0.png" (create one on paint, can be anything).
Alternatively, open each of the actors, tilesets and scenes in your game, then test your game, to force an update.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

nla2987

  • Posts: 5
Okay, I was able to fix the problem. I re-checked the boxes along with the x1, then it was asking me to generate logs again. But this time just doing what you told me to do in the first place worked. Thanks for your help!