Xcode and iOS

cgilbertson

  • *
  • Posts: 21
Ever since updating my iPhone to iOS 14, I have had an error in my logs when trying to test my game on my phone.  I'm able to run my game, but I'm met with this error (see below) in my logs, and I think it may be affecting aspects of my game.  I've updated Xcode to 12.1 and iOS to 14.1, both of which seem to be the most recent updates available.  Does anyone have any suggestions about how to solve this problem? Thank you!!

[ios-deploy] 2020-10-20 13:57:50.438 ios-deploy[14795:403108] [ !! ] Error 0xe8000022: The service is invalid. AMDeviceSecureStartService(device, CFSTR("com.apple.debugserver"), NULL, &con)[/color]
[ios-deploy] [ 95%] Developer disk image mounted successfully
[ios-deploy] [  0%] Looking up developer disk image

(@justin - I attached my logs for reference if that helps!! Thank you!)


« Last Edit: October 29, 2020, 11:31:29 am by cgilbertson »

Luyren

  • *
  • Posts: 2435
I found something similar here from August: https://github.com/ios-control/ios-deploy/issues/469
I could be completely wrong, but you might need to update Xcode. I don't know if there are more implications though. I don't have knowledge on this nor experience on mobile development, I'm afraid you'll have to wait for the devs to look into this.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

Justin

  • *
  • Posts: 4531
I've updated ios-deploy for build 10650. Please try it out and let me know if it worked for you on the issue tracker.

http://community.stencyl.com/index.php?issue=1936.0
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)