mstream: Media stream daemon stopping. [SOLVED]

redpesto

  • Posts: 134
Hi chaps,
I'm also getting the

mstreamd: (Note ) mstream: Media stream daemon stopping.
mstreamd: (Note ) mstream: mstream shutting down.

error whenever sound is (tried) to be played. Works fine in Flash. Simulator/Console chuck out the error. Will try publishing tomorrow. I added the fix (here: http://community.stencyl.com/index.php/topic,5719.0.html and it didn't change anything.

Would a full console readout be useful?

I even tried the demo games, Drop Blox et al and I get the same error,

Thanks.

« Last Edit: January 15, 2012, 03:34:48 pm by Jon »

Jon

  • *
  • Posts: 17524
Yes, a full console readout would help. This is usually not the error - the real error is elsewhere.

If the simulator isn't running, make sure you have the simulator version flipped to iOS 5 under Mobile Game Settings (a must!).

One fix that worked for another user was using the menu item "reset content and settings" in the simulator.

redpesto

  • Posts: 134
Hi Jon, the game works in the Simulator, it's just the sound that's not present. Checked the iOS5 setting in Stencyl and reset content and settings. Then I loaded up Drop Blocks. It loads and is playable but no sound. If I click the block which would trigger a sound I get the mstream error in the console. Full console read out attached...

Jon

  • *
  • Posts: 17524
Quote
11/01/2012 23:41:48.656 AppScaffold: Error loading /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn:  dlopen(/System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
  Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security

There's a bug in the iOS 5 simulator which prevents sounds playback in the simulator. I believe Apple will have fixed the bug in the next version.

redpesto

  • Posts: 134
Right you are, finally got my certs & profiles in place and published the app to my phone and it works great. Was amazing to see my little app running on my iPhone and being able to show other people - I made the whole thing from start to finish in a few hours - Stencyl is sublime, such a fast work flow from idea to iPhone.  8)

Jon

  • *
  • Posts: 17524
Glad to hear that you got this working. Looking forward to seeing what you've come up with!

redpesto

  • Posts: 134
I still get the no sound in the simulator - are we still waiting for an Apple update?

Jon

  • *
  • Posts: 17524
What  version of Xcode / iOS SDK do you have?

redpesto

  • Posts: 134
Simulator is Version 5.0 (272)
xcode Version 4.2.1, Build 4D502.
iOS SDK 5.0

Jon

  • *
  • Posts: 17524
With the latest iOS Patch, is this still a problem? We fixed a number of issues relating to recent versions of Xcode.

redpesto

  • Posts: 134
I'll just wait for 2.0 and feed back if I'm still having trouble.