[Solved] Animations Not Working

Scotty123456789

  • Posts: 10
I've been trying to set an animation for an actor to walk forward. But the animations do not work when I test the game. Walking behavior and physics are set all correctly. What is it?

« Last Edit: January 19, 2012, 05:22:55 pm by coleislazy »

rob1221

  • *
  • Posts: 9468
How do you know they are correct if the intended result doesn't happen?  You should always post the behaviors related to your problem.  Also, make sure scene gravity is set since it is 0 by default.

Scotty123456789

  • Posts: 10
The behavior is a pre made one. I even tried doing the tutorial for first games with the walking behavior from Crash Course Behavior. I got the same results where the player moved but the animations didn't work.

Hectate

  • *
  • Posts: 4645
Are you using an Animation Manager behavior in your game?
:
:
Patience is a Virtue,
But Haste is my Life.
Proud member of the League of Idiotic Stencylers; doing things in Stencyl that probably shouldn't be done.

Scotty123456789

  • Posts: 10
No I'm not using an animation manager. I even exactly followed the tutorial and the animation still didn't work. I'm not sure if flash isn't playing the animation or what it is doing. I tried the animation manager and prioritized walking over everything. It still did not work. The player stays in a Idle (R) position and does not change.

tristonhopkins

  • Posts: 69
I'm going to venture a guess that you didn't attach the "On Ground" behavior.  Just attach that and it should work.  This is of course assuming you're using the behaviors from the crash course such as Walking, Animation Manager, On Ground, etc.

Scotty123456789

  • Posts: 10
The "On Ground" behavior fixed it. I never had to use this behavior before and until yesterday it worked fine without it. Thank you. Problem solved.

Vitor456

  • Posts: 1
Still not working in mine ;-;