Game came back to a previous "saved status"

stuky

  • Posts: 20
Hi,
the problem i have is that now whenever i load my game some actors,behaviors and scenes are missing on Stencyl...basically it seems that stencyl loaded a previous "save" of the game because i haven't deleted and saved anything, in fact into the folder

C:\Users\my_username\stencylworks\games

there are all the files i've created until now.

There's a way to import again all the codes, actors, behaviors, etc... without doing all again manually? :(

captaincomic

  • *
  • Posts: 6109
Which version are you using? 1.4 or the nightly build?

stuky

  • Posts: 20
Which version are you using? 1.4 or the nightly build?

1.4.1 (b415)   

captaincomic

  • *
  • Posts: 6109
Okay, I had a similar issue when using the nightly build. I don't know if it's the same or a related issue.

stuky

  • Posts: 20
Okay, I had a similar issue when using the nightly build. I don't know if it's the same or a related issue.
I'm actually remaking all the stuff i've "lost" but i see that some thing are still here.
I mean like, "game attributes" are still here but not the normal "attributes"... I don't know it's all messed up :\
So sad, i had just finished the game and now most of it disappeared.

Konador

  • Posts: 34
I had that exact same problem with yesterday's build. Did loads of work on a a few levels but that all disappeared when I reloaded the game. Some things were still there though, like my backgrounds. Very strange!

Edit: I just tried with the newest build and still have the same problem - even when using "Save Game As" and creating a new version of the game... When I reload Stencyl, the new game is there but it has old versions of all the levels I edited (which is shouldn't because those versions of the levels never existed in that particular save of the game!).

« Last Edit: February 14, 2012, 12:11:03 am by Konador »

coleislazy

  • *
  • Posts: 2607
When you guys are having these problems, are you getting a low memory warning? If you keep working when Java fills up its allotted memory, it can start to "forget" things.

Konador

  • Posts: 34
I did get that once, but not every time it happens. I'll load up the program fresh, make a change, save the scene, close the scene, save the game and exit. When I load it back up my change is gone.

coleislazy

  • *
  • Posts: 2607
Can you reproduce this, then post your logs right after? Or, the next time it happens, post your logs? It would be helpful to see what StencylWorks is saying when it does this.

Konador

  • Posts: 34
Sure thing, it shouldn't be hard to reproduce as it happens consistently every time. I'll do it once I'm home from work in around 4 hours. Thanks for taking a look!

Konador

  • Posts: 34
Okay here are the things I did. My log is attached.

Open game

Load lvl2 (a scene)
Change background gradient
Add some tiles
Add some actors
Add a behaviour
Close/save lvl2

Load lvl1
Add a behaviour
Close/save lvl1

Load lvl3
Behaviour was already there so close/save.

Test game
My lvl1 behaviour was not there

Load lvl1
Test scene
The behaviour was there, as intended.

Travel to lvl2 from within the lvl1 test.
My tiles and actors that I added were not there.

Load lvl2
Test scene
Tiles and actors were there.


Then when I test game everything was fine. It seems I have to force it to recognise my changing by testing the scenes individually first. But, when I save my whole project and close Stencyl, the next time I load it all my changes have disappeared - whether I save normally or save as a new project.

I didn't get any 90% memory warnings.

Konador

  • Posts: 34
Anyone have any ideas? I'm about to give up on Stencyl and move to another piece of software.

coleislazy

  • *
  • Posts: 2607
The logs aren't showing anything that indicate a problem, so I'm not sure exactly how to proceed.

I remember some time ago that using "special" characters (è, ö, etc) in behaviors could cause problems with saving, but I think that was resolved. Were you using any of these kinds of characters?

I would also check some of the sample games that came with StencylWorks and see if they behave the same way, or if it just your game.

Beyond that, you may also want to back-up all your games and reinstall SW. I hope we can get this figured out!

Rob

  • *
  • Posts: 1268
Are you saying you lost some of your resources including actors and tiles? Is this very reproducible?

If so, do me a favor, and go check under your stencylworks/<your game>/resources and see if your missing resources are there.

You are on windows?

As long as the problem is reproducible, I think we can resolve it. Please put up the game here or on Forge. I would love to check it out. Give us some simple instructions.

« Last Edit: February 18, 2012, 08:14:13 am by Rob »
GOLDEN RULE #1 : SAVE YOUR GAMES FREQUENTLY
IOS/XCODE DEBUGGING
http://www.stencyl.com/help/view/xcode-ios-troubleshoot/
WATCH STENCYLWORKS VIDEO TUTORIAL BY SUNRISEKINGDOM
http://www.youtube.com/watch?v=KDfRfjzr9j4&feature=channel_video_title

Konador

  • Posts: 34
Hi guys - I just tried editing some of the bundled games, and the changes aren't saved there either so it's not something wrong with my game in particular.

All my resources are there, but anything I do like write behaviours or place tiles in scenes gets lost when I reload Stencyl. I've reinstalled several times and versions, but I've not tried clean by deleting everything. I'll try that next.