[iOS] Testing on Device - landscape scene is in portrait (SOLVED)

Hunnenkoenig

  • Posts: 399
It was caused by wrong Atlases.
I did rearrange the atlasses because I like to put everything into the right order and right category and I forgot to load a needed atlas.

Sorry if I bothered anybody  ;)

Quote
It was caused by the fact that I tried to load the same font twice.
I used it before, because I needed the same font in different sizes and I have read somewhere that you can't change the font size in the game.

I always got an error about the double load, but I could load my game anyway. I am not sure if the different font sizes really worked, because I didn't pay much attention...

Anyway, now I added only one custom font and my game loads normally.


Quote
I nailed it down to a FONT problem.
If I remove my custom font, everything works. If I set the font to a custom font, it doesn't.

I will investigate further.


Quote
I have the same problem in latest 2.0 Beta as pictured here:
http://community.stencyl.com/index.php/topic,2718.0.html

No matter what I do, my scenes start in portrait mode on iOS even if they are set in landscape.
Funny thing is, that my last added scene starts in landscape normally.
Also if I test my scenes from stencyl scene editor in flash, all of them show up correctly.

I have copy+pasted my game folder over into various new 2.0 builds.
I think, only the scenes are affected, which are made in a build before a certain version, but I don't know why.
I think it appears in the last two builds (Added Chrome store and one before), but I am not sure.

It is also to note, that only my scene background appears on the device. No actors are created etc. in those scenes which are bugged. The last scene works fine.

A fix would be nice, because I can't continue to work on the game until I can't test the scenes on a device.

EDIT2:
I now deleted all my scenes and rebuilt the first one. It is still the same.
No actors nothing, so I don't know why my other scene is working.

EDIT3: Maybe that in the attached screenshot is the problem?
I get all kind of errors if I build my game, and even if they get more and more when I go further in development, they were always there and they don't bother me much.
But this one... I don't know if it was there before.
My working scene is autorotating anyway.

EDIT4:
Maybe it has something to do with Tile sets, because the scene that works has no tiles in it, just actors as buttons.

The not working ones have tiles in it. With tiles I mean the 32x32 graphics I add from the right side as background.

I changed settings to portrait and changed resolutions and nothing works. I always get the same thing.

EDIT5:
No, it is not the tiles.
I removed all of them and it is still bugged.

« Last Edit: March 17, 2012, 12:22:25 pm by Hunnenkoenig »
Unlimited push for free: https://pushwizard.com

The entire Appstore in your Browser: http://easitunes.com

Hunnenkoenig

  • Posts: 399
It was nice to talk to myself  :D
Unlimited push for free: https://pushwizard.com

The entire Appstore in your Browser: http://easitunes.com