Example Extension Doesn't Show Up

Greyman22

  • Posts: 7
Hi There,
Its been about 10 years since I have programmed anything in Java, so im not up to speed, and not good with Eclipse, but keen to get back into it and so I was going to try my hand at an extension.

The first problem I encountered was trying to get the example extension going. It appeared in the extension directory but didn't show up in the menu so im not sure I am building it correctly and would like some clarification.

I am using eclipse indigo on a mac, and following the example extensions readme I think I added sw.jar to the classpath okay.
I configured build.xml with a name of my testextension and swworkdir.
According to the Stencylpedia on 'how to create an extension' document, you need to
"run the "dist" ANT task."
not sure what the dist ANT task it, but running ant from the command line seemed to work okay, it returned that it built successful and put "myextension.jar" into the Stencyl Extensions folder.

I am concerned with the output:
warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
(full text in attachment)

I start up Stencyl and check the extensions menu - and nothing.

I was expecting it to show up in the menu.

Any ideas on what I have done wrong - or why its not registering in the menu?

Thanks.

Greyman22

  • Posts: 7
Argh, im dumb.
I solved it, and I think I know why.

Adding sw.jar to the classpath in eclipse then compiling on the command line, probably meant that sw.jar wasn't included as I was modifying the eclipse build settings, then not using them.

I played around with Eclipse a bit, set up an ant builder in eclipse,  then in eclipse went to build > build project. The extension arrived in the right folder okay, and starting up Stencyl the extension appeared in the menu.

now I just need to learn a bit more about eclipse, dust off my java skills and start playing around to make something that does something.

Thanks.