Stencyl 2.0 Problems (SOLVED)

LionSam

  • Posts: 3
Hy guyz since I updated my Stencyl 1.4 to 2.0 this morning I have a problem all my Old games even the ones that come with the installer ask me to upgrade them, so I upgraded them but when I CLICK RUN ( TEST ) it gives me the following error to all of them :

TypeError: Error #1009: Cannot access a property or method of a null object reference.
   at stencyl.api.data::Assets$/toXML()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/data/Assets.as:145]
   at scripts::MyAssets/initMasterLists()[C:\Users\Duke\stencylworks\preview\scripts\MyAssets.as:296]
   at scripts::MyAssets/initAssets()[C:\Users\Duke\stencylworks\preview\scripts\MyAssets.as:274]
   at Function/<anonymous>()[C:\Users\Duke\stencylworks\preview\scripts\MyAssets.as:255]
   at flash.events::EventDispatcher/dispatchEventFunction()
   at flash.events::EventDispatcher/dispatchEvent()
   at flash.net::URLLoader/onComplete()


I have tried to uninstall an reinstall it and it doesn't work :(

P.S. Thanks in advance :D

« Last Edit: April 20, 2012, 04:09:25 am by LionSam »

LionSam

  • Posts: 3
So the problem i had was that i only deleted the Stencyl form C:\Program Files (x86)\Stencyl
but I needed to delete also C:\Users\Duke\stencylworks (this folder i think was corrupted when i made the update :S )

Now after the fresh :D as a daisy install it works ok :D

♥ U ALL

svintaj

  • *
  • Posts: 298
Thanks, that helped me! :)