Suggestion Issue: Android Target Version 23?


Pages: 1

Neotron

  • Level 3 Stencyler
January 16, 2017, 11:46:32 pm
Is it possible to upgrade Stencyl to handle apk builds with API level 23 or higher?
Stencyl uses Api 22 limit for a long time, but now I really need 23+ because atm I cannot update my game at Google Play.

Google says:
"It is forbidden to downgrade devices which previously used M permissions (target SDK 23 and above) to APKs which use old style permissions (target SDK 22 and below). This occurs in the change from version 6 (target SDK 23) to version 7 (target SDK 22)."
« Last Edit: January 17, 2017, 01:01:01 pm by Neotron »


Justin

  • Master Stencyler
  • *
January 25, 2018, 08:48:57 am
Going through some old issues, so this may be unhelpful to the OP, sorry.

In Stencyl 3.4, you can add the following to your advanced openfl settings.

Code: [Select]
<android minimum-sdk-version="14" target-sdk-version="23” />
This forces specific versions, but it may not work perfectly in 3.4 (it was disabled for a reason).

There's no plan for an updated 3.4 release that officially supports higher API levels than 22.
  • Status changed from New to Closed


Pages: 1

Details

  • Reported
    January 16, 2017, 11:46:32 pm
  • Updated
    January 25, 2018, 08:48:57 am

  • View Status
    Public
  • Type
    Suggestion
  • Status
    Closed
  • Priority
    Normal
  • Version
    3.4.0 beta5
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Engine

Tags