Bug Issue: Stencyl 4.1.0 Cannot change language


Pages: 1

yoplalala

  • Subscriber - Stencyl Studio
  • *
June 19, 2021, 02:12:44 am
Hi !
I cannot change the language ( tried a few of thems). When I change language, a little windown with nothing inside it appears.

No particular error in the logs

Code: [Select]
2021-06-19 11:08:04,306 DEBUG [AWT-EventQueue-0] stencyl.sw.util.FileHelper: Failed to list contents of /home/consonne/stencylworks/lang. It does not exist or is not a directory.
2021-06-19 11:08:04,307 DEBUG [AWT-EventQueue-0] stencyl.sw.util.FileHelper: Directories within lang: [lang/pt, lang/es, lang/de, lang/it, lang/pl, lang/zh, lang/ru, lang/fi, lang/zh_CN, lang/el, lang/en, lang/nl, lang/fr]
2021-06-19 11:08:04,321 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Portuguese in lang/pt
2021-06-19 11:08:04,324 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Spanish in lang/es
2021-06-19 11:08:04,326 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found German in lang/de
2021-06-19 11:08:04,327 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Italian in lang/it
2021-06-19 11:08:04,328 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Polish in lang/pl
2021-06-19 11:08:04,330 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Chinese in lang/zh
2021-06-19 11:08:04,332 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Russian in lang/ru
2021-06-19 11:08:04,333 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Finnish in lang/fi
2021-06-19 11:08:04,336 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Chinese (China) in lang/zh_CN
2021-06-19 11:08:04,338 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Greek in lang/el
2021-06-19 11:08:04,339 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found English in lang/en
2021-06-19 11:08:04,341 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found Dutch in lang/nl
2021-06-19 11:08:04,343 DEBUG [AWT-EventQueue-0] stencyl.sw.prefs.LanguagePage: Found French in lang/fr
2021-06-19 11:08:11,050 WARN  [AWT-EventQueue-0] stencyl.sw.loc.LanguagePack: Unknown locale: Chinese. Defaulting to English.


system : Linux Ubuntu 16.04
« Last Edit: June 19, 2021, 02:26:19 am by yoplalala »


Justin

  • Master Stencyler
  • *
June 19, 2021, 04:00:06 am
I'm able to switch languages with no problem, as long as I close and reopen Stencyl. Perhaps restarting Stencyl just needs to be automated?

Quote
stencyl.sw.loc.LanguagePack: Unknown locale: Chinese. Defaulting to English.
I saw that same message when I tried. Although it seems like that should cause it to fail, strangely, it still worked for me. This message is due to the custom jdk we use not including locale data, which was an oversight. I'll rebuild the jdk with locales included and reupload it.


Justin

  • Master Stencyler
  • *
June 19, 2021, 06:39:17 am
The JDK has been reuploaded with non-US locale data included.

Since not too many people have downloaded these beta builds yet, and I'm presuming that most of them don't need the extra locales, I've just replaced the existing JDK at the same URL, and I'm not forcing an upgrade.

To get the new JDK, delete your current one from $XDG_DATA_HOME/stencyl/runtimes/stencyl-jdk or $HOME/.local/share/stencyl/runtimes/stencyl-jdk and it will ask you to download the updated JDK next time you run Stencyl.
« Last Edit: June 19, 2021, 06:42:14 am by Justin »


Justin

  • Master Stencyler
  • *
June 19, 2021, 07:09:16 am
With 4.1.0-beta3/b10727, changes to language settings prompt an automatic restart of Stencyl. Including the updated JDK, everything seems to work fine here for me now. Please confirm!
« Last Edit: June 19, 2021, 07:09:34 am by Justin »


yoplalala

  • Subscriber - Stencyl Studio
  • *
June 19, 2021, 07:14:24 am
It works indeed ! :)


Issue updated by Justin - June 19, 2021, 07:20:50 am
  • Status changed from New to Resolved
  • Tags added: 4.1.0


Pages: 1

Details

  • Reported
    June 19, 2021, 02:12:44 am
  • Updated
    June 19, 2021, 07:20:50 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    UI / Workflow

Tags