Bug Issue: Lists no longer function? (b10738)


Pages: 1

suitcasenuke

  • Subscriber - Stencyl Studio
  • *
June 25, 2021, 12:47:50 pm
Hello! I'm having serious problems with lists. My entire level unlock/upgrade structure for a game I'm working on depends on both local and GA lists. I don't seem to be able to load any saved data from the GA lists anymore. As a test, I inserted some info into a GA list via the settings, but the game crashed trying to access it.

I didn't have any trouble resetting lists and writing to them via in game reset logic in b10658. Is there any way to revert properly while this is ironed out?


Justin

  • Master Stencyler
  • *
June 25, 2021, 06:16:59 pm
If you don't have a backup, the format of our data should all be the same, so you should still be able to open the game in older versions of Stencyl. It may warn you about opening a game written in a newer version, but you should be able to safely ignore that.

I'll look into this today.


Justin

  • Master Stencyler
  • *
June 25, 2021, 06:51:40 pm
I couldn't reproduce this with a very quick test.

- Create List GA, add a number, text, and boolean.
- Print value of items in list from a scene behavior.

Would you mind sending me your game and simple steps to follow for this issue? (I can check your other issue while I'm at it that way, too.)
« Last Edit: June 25, 2021, 06:53:29 pm by Justin »


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
June 27, 2021, 12:04:08 pm
I managed to fix this issue by inserting each GA list with a create new list block upon in my first scene. I suppose the game was trying to access a null list? I thought GA lists defaulted as empty lists? Anyway, that's how I fixed it.


Justin

  • Master Stencyler
  • *
June 28, 2021, 06:58:25 am
Ah, ok. I was testing with lists that had items added to them in the UI, so I didn't notice the problem with blank lists. I've fixed this in b10745 of 4.1.0-beta3.
  • Status changed from New to Resolved


kade 101

  • Junior Stencyler
September 06, 2021, 03:44:35 am
lol this still happens in 4.0.4 my list in a behaviour for actor's was working fine then next thing it bugged out and every time it tried too add a item it crashed my game even the ones that were working removed then from when made block and game ran i fixed it the same way by using create new list for my list then saving the items
i new the code was working as intended
as my game rain fine before this.....

 keep in mind all i did when this happen was add a number attribute named my cone and a second named fall of distance they were not even being saved too my list they were meant for when i make the  scenes i could change this items on the light actor too set up how the light would look
so i could use the clear /retain block with a made up image by that actor too crate a light still in progress
 my game is on windows

basically i was coding 2 lists one that is saved under the actor and 1 under game called scene light info call witch i was using too store ID's and info of all my actor lights in order by pinging my actors of group AFX lights and calling a attribute named i am saving from all in group]
and having then wait there turn too save there lists too one list buy looping call  and it was working as intended  but i did get null some times as i have a debug true/ fuse code if i ticked it under a actor in the scene it rights at each actor with group and ID and rights there info out next too then like angle X Y  am i on? and so on and it worked  now am not getting the null at all and my game loads better
i did notice it show it  might be due too me starting a list with nothing  too and adding a actor ID= name of actor in scene ] too it up first

happy this post  was here gave my problem a answer that was well dum and some how worked XD thx man i all ready spent 3 hours over my code checking it all and main i new it was correct am so all ways starting a new list with create new list
« Last Edit: September 06, 2021, 03:45:48 am by kade 101 »


Pages: 1

Details

  • Reported
    June 25, 2021, 12:47:50 pm
  • Updated
    September 06, 2021, 03:44:35 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Engine

Tags