Stencyl 3.4.0 is now out. Get it now!

Bug Issue: Linux Desktop Build: Null Function Pointer


Pages: 1

merrak

  • Expert Stencyler
  • *
June 25, 2016, 12:34:36 am
I recently exported my game through Publish -> Desktop, which produced a game that does not run. Executing it gives the error, "Null Function Pointer". Testing the game works fine, it is only the publish export that fails.

I think I have traced down the issue--or at least part of it. Publish -> Export only produces a single file, where as the testing version sits in a folder with ndll and dso files. I got the same error message by moving the test executable into its own folder, without these other files. I suspect the published version is looking for them and can't find them... but I don't know for sure.


Justin

  • Master Stencyler
  • *
June 25, 2016, 04:47:09 am
It's the same as this one, right? Though here the reported error was "Could not load module std@get_env__1".

http://community.stencyl.com/index.php/topic,46265.0.html


merrak

  • Expert Stencyler
  • *
June 25, 2016, 09:06:11 am
It might be the same issue. I got a different error message, but the problem--the stand-alone export not working--and the work-around look similar.


Issue updated by Justin - August 26, 2016, 02:20:19 pm
  • Issue Assigned from (none) to Justin


LenseOnLife

  • Subscriber - Stencyl Studio
  • *
November 19, 2017, 10:34:28 am
Hi,

I'd like to add my voice to this thread.  Using LUBUNTU 16.4 LTS and not able to execute Published games.  They work OK when testing on the Linux Platform but the output from publishing runs but nothing happens.

I've copied the 'bin' folder from the the game (in stencylworks) and it can run OK.

I've tried it on another linux machine but it says some libraries are missing (from memory I THINK it was libcc)

Oliver


Pages: 1

Details

  • Reported
    June 25, 2016, 12:34:36 am
  • Updated
    November 19, 2017, 10:34:28 am

  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    3.4.0 beta2
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Compiling/Testing Games

Tags