Bug Issue: Cannot seem to test any games.

Pages: 1


  • Subscriber - Stencyl Studio
  • *
January 02, 2018, 07:23:46 am

I have just upgraded to the latest version Beta of Stencyl and none of my games appear to be able to test. I get the following error;

[lime.utils.Assets] ERROR: There is no asset library named "default"
   at lime.utils::Log$/error()
   at lime.utils::Assets$/getAsset()
   at lime.utils::Assets$/getBytes()
   at openfl.utils::Assets$/getBytes()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/openfl/openfl/openfl/utils/Assets.hx:104]
   at com.stencyl.utils::Assets$/getBytes()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/utils/Assets.hx:37]
   at com.stencyl::Data()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Data.hx:112]
   at com.stencyl::Data$/get()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Data.hx:49]
   at com.stencyl::Engine/begin()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:780]
   at com.stencyl::Engine()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:652]
   at Universal/preloaderComplete()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/Universal.hx:360]
   at lime.app::_Event_Void_Void/dispatch()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/lime/lime/lime/_macros/EventMacro.hx:101]
   at lime.app::Preloader/start()
   at openfl.display::Preloader/display_onUnload()
   at flash.events::EventDispatcher/dispatchEventFunction()
   at flash.events::EventDispatcher/dispatchEvent()
   at openfl.display::Preloader/start()
   at lime.app::Preloader/updateProgress()
   at lime.app::Preloader/current_onEnter()

Any Help would be appreciated.
« Last Edit: January 02, 2018, 08:09:00 am by kinlaap »

Issue updated by kinlaap - January 02, 2018, 08:09:00 am
  • Category changed from (none) to Compiling/Testing Games


  • Master Stencyler
  • *
January 11, 2018, 04:30:42 am
What platforms are you trying to test? Can you attach your logs?
  • Status changed from New to Need Info


  • Subscriber - Stencyl Studio
  • *
January 16, 2018, 01:56:13 am

Sorry for the lateness in getting back to you. I appreciate your time in looking at this. I seem to have resolved the issue. Think it was just a couple of bugs with my system.

Issue updated by Justin - January 16, 2018, 03:20:14 am
  • Status changed from Need Info to Closed


  • Junior Stencyler
January 16, 2018, 07:53:35 pm
Hi I cannot test my game either and I think the error may be due to me entering the wrong system password...I used my laptop password instead of the stencyl one because it told me to download some extension to view the game


  • Junior Stencyler
January 22, 2018, 11:36:55 am
I am teaching Stencyl. I upgraded my mac to High Sierra and  I am unable to test or run any game since. I have the log


  • Junior Stencyler
January 22, 2018, 11:37:38 am
I don't know how to attach the logs.

Pages: 1


  • Reported
    January 02, 2018, 07:23:46 am
  • Updated
    January 22, 2018, 11:37:38 am

  • View Status
  • Type
  • Status
  • Priority
  • Version
    3.5.0 beta 1
  • Fixed in
  • Assigned to
  • Category
    Compiling/Testing Games