Stencyl 3.4.0 is now out. Get it now!

Bug Issue: Load Game - lists game attributes not loading.


Pages: 1

Luyren

  • Master Stencyler
  • *
July 26, 2017, 11:17:23 am
b9480, running on Windows

When testing on Windows Export, HTML5 and Cppia, loading a save will not reset a game attribute of type list.

Test Case (attached): I save the game in a When Created event to store the initial values. I then change all the values, load game and reload the scene. The values I added to the list don't reset to the initial value I saved, while text and number game attributes are loaded properly. All the logic is in the Scene Event.

In Flash, the list is loaded properly.

Value of Game Attribute blocks are also not loaded if they weren't defined in the first place, but I can see why they wouldn't and I have a work around for them.

Controls for the Test Game: arrows will change the list, text, number or value of game attribute, and Enter will load game and reload the scene.
« Last Edit: July 26, 2017, 11:18:50 am by Luyren »


New attachment added by Luyren - July 26, 2017, 11:17:42 am


Justin

  • Master Stencyler
  • *
September 06, 2017, 02:34:24 pm
Fixed, b9502.
  • Status changed from New to Resolved
  • Issue Assigned from (none) to Justin


Luyren

  • Master Stencyler
  • *
September 06, 2017, 07:05:22 pm
Tested on b9504 on the test game I attached. I'm getting a #1034 error on the save block on Flash and HTML5 (that's an assumption on HTML5, as I don't get a pop up error there but nothing is being drawn), and getting a "Bad Link" error pop up on Ccpia, so I can only confirm it is fixed on the Windows export option.


Justin

  • Master Stencyler
  • *
September 06, 2017, 07:30:08 pm
Cppia is fixed with b9506 (remember to rebuild host).

I'll check flash in a moment.


Issue updated by Justin - September 06, 2017, 08:24:58 pm
  • Status changed from Resolved to Assigned


Justin

  • Master Stencyler
  • *
September 06, 2017, 10:38:14 pm
Fixed the error, b9510. Works in flash, html5, and native.
  • Status changed from Assigned to Resolved


Luyren

  • Master Stencyler
  • *
September 07, 2017, 09:50:10 am
b9510, fixe confirmed in Flash, HTML5, Windows and Ccpia. Got to compile on all those with this build.
« Last Edit: September 07, 2017, 09:58:39 am by Luyren »


Justin

  • Master Stencyler
  • *
September 07, 2017, 10:53:47 am
Thanks! Glad to hear some good news in these troubled times with nobody able to compile anything. :D
« Last Edit: September 07, 2017, 10:53:59 am by Justin »


Pages: 1

Details

  • Reported
    July 26, 2017, 11:17:23 am
  • Updated
    September 07, 2017, 10:53:47 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Design Mode Blocks

Tags


Attachments

* test save.stencyl (287.4 kB - downloaded 8 times.)