Bug Issue: Build 9328 Cppia Scaling Not Working

Pages: 1


  • Subscriber - Stencyl Studio
  • *
June 21, 2017, 11:03:11 am
Unable to use the latest private build and unable to use the public build 9300, I have now tried build 9328 (recommended on the download page) and when it runs using 'stretch to fit' scaling at 2x in fullscreen, I get the results in the attached PNG. The upper left quadrant highlighted in pink is what is supposed to be stretched across the screen. I get various incorrect results when I select other methods, too. Scale to Fit just makes the game smaller than 'no scaling' and 'fullscreen' scaling goes too far, effectively zooming in on the game to the point where the player actor is almost half the size of the screen. Only "scale to fit (letterbox)' seems to work correctly, except when I make the game resolution 640x360, at which point this scale mode crashes on startup.

I used to be able to get build 9300 to run, and when I did, I got the same incorrect scaling results I've outlined above.

These scaling problems seem to be fixed in the 3.5 build -- but for reasons outlined in a different bug report, I can't use that build either (and I imagine you would want to fix a problem with the public build, anyway.)  I've also attached the logs if that helps at all.

If I'm not providing something you need, please let me know and I will provide it. I am happy to send the game privately if that will help. Thanks.

Edit: I've compiled for desktop, gotten the same results and attached the desktop logs if those are more helpful.
« Last Edit: June 21, 2017, 06:02:24 pm by BMJ »

New attachment added by BMJ - June 21, 2017, 11:04:28 am

New attachment added by BMJ - June 21, 2017, 11:04:57 am

New attachment added by BMJ - June 21, 2017, 11:05:13 am


  • Subscriber - Stencyl Indie
  • *
June 21, 2017, 03:28:05 pm
Is there a reason why you set it to "2x" ?
Why not just go with the default "1x" ?
You mean't the "Desktop>Settings>Scale" right?
Unless I misunderstood something, you should stick to "1x".

Works fine on my end with Build 9328 and below.
But any Build past that (with the new OpenFL), the scaling are totally broken for me.

Doesn't seem like anyone is interested in touching the scaling code on the new Build, for now.
Its the only thing that stops me from migrating to the latest private version.
Hope it doesn't take more than a year, before someone finally look into it, like the old scaling fix.

New attachment added by BMJ - June 21, 2017, 06:01:53 pm


  • Subscriber - Stencyl Studio
  • *
June 21, 2017, 06:22:23 pm

THANK YOU. The problem was setting the scale to 2x instead of 1x. Once I set it to 1x, the scaling works for me in build 9328. That was never a problem in earlier versions of Stencyl (I've been using for 3 years) and should probably still be addressed as Stencyl says "does not apply if running in full screen mode" directly next to the scale setting, leading one to believe it's irrelevant. It's not irrelevant at the moment, apparently. :P It must be set to 1x to work properly for fullscreen.

One  thing -- the scaling is still messed up when choosing scale mode "full screen". (I'm talking about the second dropdown box, not the tick box at the bottom.) It still gives the result outlined in my first post. I don't need this mode, personally, but it still might be an issue for others.


  • Master Stencyler
  • *
February 04, 2018, 01:16:17 am
Closing since this is a 3.4-only issue.
  • Status changed from New to Closed

Pages: 1


  • Reported
    June 21, 2017, 11:03:11 am
  • Updated
    February 04, 2018, 01:16:17 am

  • View Status
  • Type
  • Status
  • Priority
  • Version
    Stencyl 3.4, 3.4.0 beta5
  • Fixed in
  • Assigned to
  • Category



* Cppia 2x - stretch to fit - 2x - fullscreen.png (3164.01 kB, 1920x1080 - viewed 55 times.)
* log-2017-06-21 Cppia 2x-stretch to fit - 2x - fullscreen.zip (112.14 kB - downloaded 30 times.)
* log-2017-06-21 b9300 crash on start of game.zip (197.06 kB - downloaded 29 times.)
* BMJ desktop logs for scaling issue build 9328.zip (311.83 kB - downloaded 24 times.)