Stencyl 3.4.0 is now out. Get it now!

Bug Issue: Can't Test After Cleaning Project


Pages: 1

ozz

  • Subscriber - Stencyl Indie
  • *
April 12, 2017, 06:19:09 pm
I hadn't cleaned my game in a while and was having an issue with the map system, despite not having touched that component for months so I used the "Clean Project" function and now I  can't test.

Here are my logs:
https://mega.nz/#!RExjFZyY!dDxHdUjncWYNuYiNXlthsCp81-HRIb5KCsCPnziR1KY
« Last Edit: April 12, 2017, 06:21:16 pm by ozz »


rob1221

  • Master Stencyler
  • *
April 12, 2017, 06:32:36 pm
Quote
Font file missing for font "Tutoral": X:\stencylworks\games\Broken\hx\font-17.fnt - converting.
org.newdawn.slick.SlickException: Unable to load Hiero font file: font.size=20
Try opening and resaving the font and if that doesn't work, delete and recreate the font.
  • Status changed from New to Need Info


ozz

  • Subscriber - Stencyl Indie
  • *
April 12, 2017, 06:47:02 pm
Thanks for responding, thing is I tried to do just that just before posting.   Only I don't have any fonts/types/sources called Newdawn, Slick or Hiero, so I'm not really sure what font 17 is or how to find it.


rob1221

  • Master Stencyler
  • *
April 12, 2017, 07:45:15 pm
17 is the resource ID.  You should see the font in your game's resources folder.


ozz

  • Subscriber - Stencyl Indie
  • *
April 13, 2017, 08:24:14 am
I think this might be an issue with the engine, it's not just one font it's every font, including those that came packed in with Stencyl Works (i.e: Newspaper, San Serif, Typewriter). 

I edited them all and then restarted SW, but upon restart all the fonts were gone. 

The game would test again at this point, but as soon as I recreated one of the fonts the test would fail in the same way, with the logs saying the error was with the new (and only) font.

It seems any fonts at all will crash my game.
« Last Edit: April 13, 2017, 09:28:13 am by ozz »


rob1221

  • Master Stencyler
  • *
April 13, 2017, 09:47:10 am
Have you tried reinstalling Stencyl?


ozz

  • Subscriber - Stencyl Indie
  • *
April 13, 2017, 10:15:14 am
Thanks, after hunting down every font file in the resources folder and deleting them (SW wasn't showing them, but they were still in there) I installed the lastist version.  It seems to be working now, though I'm going to have to Rebuild all the fonts and the map systems still broken.  It seems unrelated to what happened with the fonts as there are none in that behavior.
« Last Edit: April 13, 2017, 10:18:10 am by ozz »


rob1221

  • Master Stencyler
  • *
April 13, 2017, 10:58:45 am
If you still can't test, what do the logs say now?


ozz

  • Subscriber - Stencyl Indie
  • *
April 13, 2017, 11:35:11 am
I can test now, that part is working again.  I think I can take it from here.  Thanks for your help.


Issue updated by rob1221 - April 13, 2017, 12:54:35 pm
  • Status changed from Need Info to Closed


Pages: 1

Details

  • Reported
    April 12, 2017, 06:19:09 pm
  • Updated
    April 13, 2017, 12:54:35 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    Stencyl 3.4, 3.4.0 beta4
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Compiling/Testing Games

Tags