Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - taulant

Pages: 1
1
@Justin thanks for the link.

I followed the instructions and the licenses were accepted in the terminal but I am still getting errors in the log. They are slightly different this time but still license related. I am a bit at loss.

Can anyone please look at the logs to make sense of it? Attaching in the original post.
Code: [Select]
log-2019-04-26.zip

2
Ask a Question / How to solve Android API version 26 compile errors?
« on: April 25, 2019, 12:48:48 pm »
Currently experiencing some issues during compiling for Android. The game I have made runs fine as an HTML game so I know it's not a problem with the game but with how the Android game is compiling.

My current setup:
MacOs High Sierra v 10.13.6
Stencyl v4.01
Android Minimum Version: API 26 8.0.0
Android Target Version: API 28 9.0

I've looked at the logs and there are issues with licenses. I tried to run
Code: [Select]
$ ./sdkmanager --licenses but it is not allowing me do that in the /stencylworks/ android-sdk/android-skd-macosx/tools/bin folder.

I am attaching the log for more info.

3
Ask a Question / Re: How to set the API on Android to 26
« on: April 25, 2019, 12:37:12 pm »
Thanks for your recommendations @Justing & @corbanwolf. Updating to Stencyl 4.0.1 helped. I was able to set the Android API to 26. I am however experiencing new issues during compiling for API version 26. I will open a new thread for that.

4
Ask a Question / Re: How to set the API on Android to 26
« on: April 24, 2019, 03:59:06 pm »
That is where I was selecting but it is not letting me go higher than 22. I need to have at least API level 26 to be able to upload on the Play Store. See attached image.

Quote
settings -> mobile -> versions
make sure you have the latest version of stencyl too

5
Ask a Question / How to set the API on Android to 26
« on: April 24, 2019, 01:12:38 pm »
When I upload the APK I get this prompt from the Goole Play Store
Quote
Upload failed
Your app currently targets API level 16 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance. Change your app's target API level to at least 26. Learn how.

Meanwhile Stelncyl doesn't allow selection above API level 22.

I looked in the forum and the recommendation was to set the edit Openfl settings to the line below
Code: [Select]
<android minimum-sdk-version="26" target-sdk-version="26” />
Doing this just throws an error. I am attaching the error log for more information.

I am really disappointed as I just paid $199 to be able to publish my game.  :(

6
Ask a Question / Re: Error while building on new laptop
« on: January 04, 2015, 02:38:00 pm »
I am getting the same log message.

7
Bug Archives / Compiling for iOS 3.5" gives me this error message
« on: January 04, 2015, 02:05:55 pm »
Code: [Select]
Level:     ERROR
When:      2015-01-04 16:59:52
From:      stencyl.sw.app.filewatcher.ExternalAppLauncher

Couldn't locate com.apple.iphonesimulator.plist for switching to retina

Anybody know what is causing this error log?

Pages: 1