Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - xtrode

Pages: 1 2
1
Ask a Question / Android Publish error (missing JAR file?)
« on: October 14, 2016, 03:22:35 pm »
So I was able to publish an iOS IPA, but publishing the android it fails to finish building after it's finished compiling. It states that it's not a bug, but rather a configuration problem, most likely a missing JAR file.

I've attached my logs, but I'm not sure what I would need to add, or even where I would get the missing JAR file. Any advise?

2
Ask a Question / Re: Click to move confusion
« on: June 25, 2016, 10:34:04 pm »
Bump

3
Ask a Question / Click to move confusion
« on: June 23, 2016, 11:22:15 pm »
I'm using a behavior from Stencylforge called Click to Move, but whenever the camera follows the main actor away from x 0 and y 0, the actor no longer stops where the mouse Click happened. I know I should probably + or - something, but I can't figure it out. Any help?

4
Did you get all the atlases individually under 15mb or the memory use of the scenes below 15mb?

5
Still a no go. Even with all the scales enabled in both settings and the mobile tab, it doesn't open.

6
I uploaded them at 2x, so that's why 3x and 4x aren't included. I do have the resources divided  between the 4 atlases. It says the memory use is 58mb for 2x and 37mb for 1x.

7
Ask a Question / Simulator runs game, IOS doesn't. Help!?
« on: May 16, 2016, 11:30:12 pm »
I can test my game in the simulator and it runs just fine, but when I test it on my iPhone, it sends to the device but won't open past the splash screen. Most of the time no errors, but sometimes it says it does, but also still has the "Now launch game on device" window. (i've uploaded the logs from that occasion). Any advise?

I've had this issue before running it at 2x, but was able make it open by only having 1.5x or 1x, but since the Stencyl Beta 3 update, those no longer work either.

Any ideas, or thoughts are appreciated.

8
iPhone / iPad / Android / Simulator runs game, iOS doesn't. Help!?
« on: May 16, 2016, 11:26:45 pm »
I can test my game in the simulator and it runs just fine, but when I test it on my iPhone, it sends to the device but won't open past the splash screen. Most of the time no errors, but sometimes it says it does, but also still has the "Now launch game on device" window. (i've uploaded the logs from that occasion). Any advise?

I've had this issue before running it at 2x, but was able make it open by only having 1.5x or 1x, but since the Stencyl Beta 3 update, those no longer work either.

Any ideas, or thoughts are appreciated.

9
Ask a Question / iOS Simulator works, but not on iPhone.
« on: May 15, 2016, 10:36:12 pm »
So I've been testing my game and have always had problems when testing on my iPhone when I ran it at 2x (what I uploaded at), even though it worked fine in the simulator. The only way I could get it to open would be to exclude 2x from the iPhone build. But now with the Stencyl Beta 3, even at 1x it won't open, but yet the simulator still works fine. Does anyone have experience with this issue that might be able to advise?

10
Extensions / Re: Virtual Joysticks Extension [3.1]
« on: May 09, 2016, 11:52:36 pm »
Both the extension, and the newly implemented blocks in Stencil 3.4 have an issue with the 5.5" iPhone. It works great on every other size, just doesn't work at all on this size.  Any help?

11
Ask a Question / Play Sound not working with OGG.
« on: October 01, 2015, 09:52:49 pm »
So I the behavior I have set up is super basic. Player enters region or collides with actor, then stop all sounds, then play sound.

I'm testing on mac, not flash, checked atlas'. I really can't seem to figure it out. The only way I can get the sound file to play is if I have the sound play when the scene is created, but I need it to play from a region or actor. It just doesn't play when I set it up that way.

It's almost as if there is a bug in stencyl  3.3.2

When I was testing the game in flash using mp3's, they played just fine, but  when I test on mac with Ogg, it just doesn't work. And I can't seem to figure out why it won't.

Any advise?

12
Ask a Question / Bring an object with you through scene change?
« on: July 20, 2015, 05:41:31 pm »
How would you push an object through a scene (door behavior) and have it appear on the next scene with you?

13
Paid Work / Re: Need some behaviors made
« on: June 24, 2015, 11:02:40 am »
Ok, how would I go about having the songs be unlocked once you complete a level? Each song would have to correspond with it's level and the levels can be completed in any order.

14
Ask a Question / Re: Actor to face player?
« on: June 24, 2015, 10:31:09 am »
Update: So I finally got it to work, but only after setting up both behaviors in the scene. I was hoping to make an actor behavior for this, so I could easily apply it to each of the actors. But if it doesn't work that way, I guess I'll just set up multiple scene events for each actor.

Any advise on how to do this with actor behaviors instead of scene behaviors would be helpful.

15
Ask a Question / Re: Actor to face player?
« on: June 24, 2015, 10:18:06 am »
I'll try your way T4u, although I can't seem to figure out how to "set <Player> to Last created actor"

Merrak, I set up attributes for the animations, so I shouldn't need to type the name, but I tried it without the attributes, just typing the name of the animation and I still can't seem to make it work.

Pages: 1 2