Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Vorens Studios

Pages: 1
1
Ask a Question / Re: Fixed bugs in newer builds?
« on: January 10, 2019, 09:51:54 am »
I messed up. I meant to upload a project file instead of APK.

Can someone with the latest build install this project file and test it to see if there are still issues? (Issues that appeared in 3.5.0 (Build 9987 or prior) and not in 3.4.0 (Build 9300) are described in the project).

Project is available HERE.

Thank you,
Jani

2
Ask a Question / Fixed bugs in newer builds?
« on: January 07, 2019, 01:41:09 pm »
Hello!

I am wondering if the issues mentioned in the bug report #1328 are fixed in the newer builds?
If not, is there any workaround to get everything to work without those issues?

 I attached the APK file to that report. I would really appreciate it if someone with the newest build could check it out to see if the problems still exist.

Project is available HERE.

Thank you,
Jani

3
Immersive mode is probably working as intended. I had the same issue on Google Pixel 2 XL and the problem (black bar) was caused by the default aspect ratio. You can change that in AndroidManifest.xml located in "C:\Program Files (x86)\Stencyl\plaf\haxe\lib\lime\lime\legacy\templates\android\template".

Open AndroidManifest.xml and add this code inside <application> tag:
Code: [Select]
<meta-data android:name="android.max_aspect" android:value="2.1" />
By adding this line you should get rid of that black bar.

I hope this works for you,
Jani

4
Ask a Question / Re: Black lines showing on Android devices ...
« on: February 20, 2017, 02:02:42 pm »
Changing Android or Stencyl versions isn't going to change the result.  The problem is caused by how OpenFL renders images when there's a combination of scaling and antialiasing.  If the update to OpenFL 4 (probably within the next few months) does not fix this problem I will spend some time in the Stencyl engine trying to find a workaround.

I see. Hopefully the new OpenFL update will fix these issues like you said.  :)

Thank you both for your replies,
Jani

5
Ask a Question / Re: Black lines showing on Android devices ...
« on: February 20, 2017, 12:05:10 pm »
I was trying to see if that bug was in the game or software, so I created another game to test those tiles and the problem is still there while testing on Motorola Moto G4.

Can updating Android API fix anything like that?

Currently it's set to:
Minimum: API 9 - 2.3 (Gingerbread)
Target: API 16 - 4.1 (Jellybean)

I'm not sure if reinstalling Stencyl would help as it was recently updated to Build 9300 and the problem was here before that.
Possibly Stencyl bug like you mentioned?

Thank you,
Jani

6
Ask a Question / Re: Black lines showing on Android devices ...
« on: February 20, 2017, 06:38:43 am »
I've had a look at the images and they seem fine.

In your project folder, find and examine the images for the scales that are affected. Maybe it's occurred when the images were resized.

I attached images from resources folder below. Looks good to me.

Another thing I forgot to mention that the problem sometimes disappears when player is closer to the water or when turned in the opposite direction but appears again when the player starts to move, as can be seen on the video (camera movement).

Thank you,
Jani

7
Ask a Question / Re: Black lines showing on Android devices ...
« on: February 20, 2017, 02:46:42 am »
It looks like it's an issue with your image as it seems to occur with the same frame of your water animation, though it's strange that it's not appearing on all devices. (Maybe it's only visible at certain scales/resolutions?)

I'd inspect your images carefully. Look at left and right edges to see if you can see anything. Could you also post the original images here?

Thank you for reply! I guess this is only affected on certain resolutions and scales just like you said. On Buestacks I tried different resolutions and everything worked fine.

Original water frames are attached below. (The second frame is just like the first frame but flipped horizontally)

Thank you,
Jani

8
Ask a Question / Black lines showing on Android devices ...
« on: February 19, 2017, 01:11:35 pm »
Hello everyone!

While testing our game on Android mobile devices, we noticed that there are visible black lines on some tiles or actors (depends on device that we test on)

Example: On Motorola Moto G4 there appears to be black (transparent, as you can see the backgound) line between animated water tiles, as you can see in the video below. (This doesn't happen on Motorola Moto G)
Another Example: On Motorola Moto G there appears to be black lines above player while walking. (This doesn't happen on Motorola Moto G4)

Video

There is no problem while testing on Flash or Bluestacks emulator.

I already checked resources folder and everything seems to be fine there.
Every graphics was imported at 4x scale using Bicubic resizing method.

Stencyl Build: 9300
Screen Size: 480 x 320 px
Antialiasing: On

Quote
Game Settings - Mobile - Display

Settings
Orientation - Landscape
App Type - Universal
Framerate - 60 FPS

Scale Mode
Android - Scale to Fit (Full Screen)

Scales
Android - 1x, 1.5x, 2x, 3x, 4x

I will provide more information if needed.

Thank you,
Jani

9
Ask a Question / Re: A few questions before purchasing Studio license ...
« on: January 17, 2017, 12:40:16 pm »
The black outline won't be completely gone until the OpenFL update that was discussed in the thread you linked to.

I see. Any idea when that update will be available?

Looks like it still carries some small traces.
You have to wait for the next Stencyl update with the latest OpenFL then.

Alternatively, if you can't wait and are willing to do the manual tedious workaround.
You need a Photoshop (its possible to use other graphic programs but I only use PS)
Follow the steps bellow :

- Open the original images
- Scale the original images manually in PS into all the scales
   (you can refer with the one in "../stencylworks/games/[GameName]/resources/" as a guide)
- Click "File>Export>Render Video..."
- Rename it to the same name located in "../stencylworks/games/[GameName]/resources/"
- Under [File Options - QuickTime Export],  choose -> [Image Sequence]
- Press "settings", then choose "PNG"
- Then press "Options", and select "Million of Colors+", then press "OK", and "OK"
- At the main pop-up window under "Render Options>Alpha Channel",
  select "Premultiplied with Color"
- Click the colored square beside it, and change the color to --> R:180 | G: 180 | B: 180
  (This number can be any shades of grey, 180 is just what I usually use.)
- After all images have been fixed
- replace all the images in the "../stencylworks/games/[GameName]/resources/" with the new ones
- Open game project
- Run>Clean Project
- Test

It works for me. Hope it works for you too.


Thanks for that. I will see what it can be done. Otherwise we will have to wait for OpenFL update.

Thank you,
Jani

10
Ask a Question / Re: A few questions before purchasing Studio license ...
« on: January 17, 2017, 09:13:05 am »
Can you show us some screenshots? I have never seen this happening before so maybe the problem lays with the source images?

Images are attached. You can see the difference on second image (Black outline and blurry).

Have you completely removed the old graphics before reimporting them?

Yes.

Thank you,
Jani

11
Ask a Question / Re: A few questions before purchasing Studio license ...
« on: January 17, 2017, 07:48:45 am »
After reimporting them, make sure you do a "Run>Clean Project" before testing.
See if that makes any difference.

There is an old workaround. But I don't think its necessary now that its already been fixed in b9203.


Thank you for reply! I tried this just now and still the same problem. I forgot to mention, that this has been happening for months and that I have done "Clean Project" on earlier backups with no luck.

Any other suggestions?

Thank you,
Jani

12
Ask a Question / Re: A few questions before purchasing Studio license ...
« on: January 17, 2017, 05:12:18 am »
After reimporting everything, the issues 1, 2 and 3 are still occurring on Android. I also reinstalled Android SDK to see if it makes any difference but still nothing.  :(

Is this still a bug?

Thank you,
Jani

13
Ask a Question / Re: A few questions before purchasing Studio license ...
« on: January 17, 2017, 12:14:12 am »
1,2,3 ---> If your graphics were imported with a Stencyl version prior to b9203, try to reimport them again.
4 ---> I think not yet.

Thank you for reply! I will definitely do that later today as we are on build 9279 and most images were imported way before b9203.

Thank you,
Jani

14
Ask a Question / A few questions before purchasing Studio license ...
« on: January 16, 2017, 12:25:57 pm »
Hello everyone! :)

Our platformer game for Android is almost finished and before purchasing Studio license I have a few questions about Stencyl (bugs / problems), that only occur while testing on Android and not on Flash.

  • While testing on Android, there appears to be black outline on almost every actor. Same issue was reported here: http://community.stencyl.com/index.php?topic=47255.0
  • Actors seem to be blurrier and washed out on Android compared to Flash. (Connected to question 1?)
  • On Android, if player actor is walking to the right and then turns left, there appears to be invisible line between actor and tiles. It looks like the actor is levitating. This only happens on Android devices. (Also connected to question 1?)
  • Is there any extension or workaround to support Android TV?

All image assets were imported at 4x scale using Bicubic resizing method.
Is there any fix for those issues?

Quote
Game Settings - Mobile - Display

Settings
Orientation - Landscape
App Type - Universal
Framerate - 60 FPS

Scale Mode
Android - Scale to Fit (Full Screen)

Scales
Android - 1x, 1.5x, 2x, 3x, 4x

Thank you,
Jani

Pages: 1