Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - CTWitt

Pages: 1
1
Ask a Question / Re: One of my Scenes stopped working!
« on: March 28, 2019, 09:18:21 am »
I tried Rob's suggestion as well, and so far it seems to have worked in my case too! Thanks Rob!

2
Ask a Question / Re: One of my Scenes stopped working!
« on: March 27, 2019, 03:06:29 pm »
Sorry to be Mr. Clueless, but when you say constrain the index and create a warning in the logs, what does that actually mean I should do to accomplish that? Is there something I can do to adjust the index in the scene's xml file? I'd really appreciate any clarification.

3
Ask a Question / Re: One of my Scenes stopped working!
« on: March 24, 2019, 07:07:07 pm »
Hi. Unfortunately another scene I was working on has stopped letting me open it.   ::) I've attached the error log. I don't think I removed any actor types from the game that were still in the scene this time, so I could use some help figuring out what the problem might be.

4
Ask a Question / Re: One of my Scenes stopped working!
« on: March 19, 2019, 05:34:05 pm »
In this case it shouldn't be that big of a hassle. I'm more focused setting up actor behaviors, events, etc. than level/scene design at this point. I am pretty sure the actor no longer existing had something to do with it, so if nothing else I'll make sure to be more careful about deleting/removing actor types in the future.

5
Ask a Question / Re: One of my Scenes stopped working!
« on: March 19, 2019, 03:49:34 pm »
No, it still brought up the same error box and wouldn't open.

6
Ask a Question / Re: One of my Scenes stopped working!
« on: March 19, 2019, 02:38:06 pm »
Yeah, I saw someone mention that concept in another thread about a similar problem. I opened up the XML file for the scene and took out the line that directly mentioned the actor type, but despite the alteration I still haven't been able to open the scene up. What all does one do to remove code that references a non-existent actor without messing something else up?

7
Ask a Question / One of my Scenes stopped working!
« on: March 19, 2019, 11:01:51 am »
Hi all. I started using and learning about Stencyl a few weeks ago, so I'm no expert. Recently a scene I had been working on stopped allowing me to view and/or edit it. It had been working fine the last time I was editing it, but the next time I tried to open the scene an error box came up requesting I create a log, and I haven't been able to open the scene since. (technically the log I attached isn't the first one that was created, but I thought it would be best to share the most current one if there was any difference.) I don't have many scenes at this point, but the rest of them are still able to open like normal. Any suggestions?

Pages: 1