Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - sparkyidr

Pages: 1 2 3 4
31
Old Questions (from 1.x/2.x) / Re: Game stuck on "Replace Me" on iPhone
« on: February 18, 2012, 06:12:23 am »
Hey Jon.

I'm not sure what you are asking me there.

The crash log I attached is from the xcode organiser....where do I need to drag it in? And what output do I need to show you?

Sparks.

32
Old Questions (from 1.x/2.x) / Re: Game stuck on "Replace Me" on iPhone
« on: February 17, 2012, 12:18:03 pm »
Attached the latest crash log from a test run just now


edit: added a txt version

33
Old Questions (from 1.x/2.x) / Re: Game stuck on "Replace Me" on iPhone
« on: February 17, 2012, 10:14:18 am »
That's pretty unusual that it works on the simulator but not the device. Is there any more to the error message than that?

That's basically everything that the console spewed out from the time I hit the "play" (build) button in xcode, to the time I hit the "stop" button to force the app to stop running on the phone.

Works fine if I test in simulator, but it behaves exactly the same way every time I use test on device 100% of the time.
Also does the same if I test on my housemate's ipad.

Just done another test and here is the console output....just incase anything that was different this time is useful.


Code: [Select]
Feb 17 18:12:00 unknown securityd[1617] <Notice>: MS:Notice: Installing: (null) [securityd] (675.00)
Feb 17 18:12:00 unknown kernel[0] <Debug>: lockbot[1545] Builtin profile: gputoolsd (sandbox)
Feb 17 18:12:01 unknown installd[1515] <Error>: 016b7000 load_application_info: Could not load signer identity from /private/var/mobile/Applications/98A2ECC4-A8E8-41A9-A54D-E6889957D2E9/AppScaffold.app/AppScaffold
Feb 17 18:12:01 unknown SpringBoard[26] <Warning>: Reloading and rendering all application icons.
Feb 17 18:12:03 unknown sandboxd[1628] <Notice>: MS:Notice: Installing: (null) [sandboxd] (675.00)
Feb 17 18:12:03 unknown com.apple.debugserver-64[1627] <Warning>: debugserver-64 for armv6 Copyright (c) 2007-2009 Apple, Inc.  All Rights Reserved.
Feb 17 18:12:03 unknown com.apple.debugserver-64[1627] <Warning>: Connecting to com.apple.debugserver service...
Feb 17 18:12:03 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.yourname.gamename[0x1dfb]) Spawned and waiting for the debugger to attach before continuing...
Feb 17 18:12:03 unknown com.apple.debugserver-64[1627] <Warning>: Got a connection, waiting for debugger instructions for task "(null)".
Feb 17 18:12:04 unknown kernel[0] <Debug>: lockbot[1545] Builtin profile: debugserver (sandbox)
Feb 17 18:12:04 unknown kernel[0] <Debug>: launchd[1630] Builtin profile: container (sandbox)
Feb 17 18:12:04 unknown kernel[0] <Debug>: launchd[1630] Container: /private/var/mobile/Applications/98A2ECC4-A8E8-41A9-A54D-E6889957D2E9 [69] (sandbox)
Feb 17 18:12:33 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:33 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:34 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:34 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:34 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:34 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:35 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:35 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:36 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:36 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:36 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:36 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:36 unknown com.apple.locationd[50] <Notice>: NOTICE,received EBUSY, try kScanTypeChannel, channel, 11, rssi -85, delayed 63.856s
Feb 17 18:12:37 unknown kernel[0] <Debug>: AppleBCMWLANCore:isScanAllowed(): Device is in low signal area, Rssi -78 and could potentially roam
Feb 17 18:12:37 unknown kernel[0] <Debug>: AppleBCMWLANCore:setSCAN_REQ(): rejecting a low priority scan
Feb 17 18:12:56 unknown securityd[1631] <Notice>: MS:Notice: Installing: (null) [securityd] (675.00)
Feb 17 18:12:59 unknown ReportCrash[1636] <Notice>: MS:Notice: Installing: (null) [ReportCrash] (675.00)
Feb 17 18:12:59 unknown ReportCrash[1636] <Notice>: Formulating crash report for process AppScaffold[1630]
Feb 17 18:12:59 unknown com.apple.launchd[1] <Notice>: (UIKitApplication:com.yourname.gamename[0x1dfb]) Bug: launchd_core_logic.c:3730 (25147):3
Feb 17 18:12:59 unknown com.apple.launchd[1] <Notice>: (UIKitApplication:com.yourname.gamename[0x1dfb]) Assuming job exited: <rdar://problem/5020256>: 10: No child processes
Feb 17 18:12:59 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.yourname.gamename[0x1dfb]) Job appears to have crashed: Segmentation fault: 11
Feb 17 18:12:59 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.yourname.gamename[0x1dfb]) Throttling respawn: Will start in 2147483592 seconds
Feb 17 18:12:59 unknown SpringBoard[26] <Warning>: Application 'platformer' exited abnormally with signal 11: Segmentation fault: 11
Feb 17 18:12:59 unknown ReportCrash[1636] <Error>: Saved crashreport to /var/mobile/Library/Logs/CrashReporter/AppScaffold_2012-02-17-181259_Sparkys-Iphone.plist using uid: 0 gid: 0, synthetic_euid: 501 egid: 0

34
Old Questions (from 1.x/2.x) / Re: Game stuck on "Replace Me" on iPhone
« on: February 17, 2012, 05:34:29 am »
I get the same thing every time.

99% of the time, if I wait for a while (a minute or so) and then hit the stop button in xcode...and then wait some more, the app eventually stops running, throwing me back to my homescreen. Then I can run it from the homescreen icon on the phone, and it works as expected.

Not ideal...but kinda works.

Just done a test right now, and here is the console output from hitting the build button, to the app quitting back to the homescreen after I hit stop in xcode


Code: [Select]
Feb 17 13:30:42 unknown securityd[335] <Notice>: MS:Notice: Installing: (null) [securityd] (675.00)
Feb 17 13:30:43 unknown kernel[0] <Debug>: lockbot[337] Builtin profile: gputoolsd (sandbox)
Feb 17 13:30:44 unknown installd[310] <Error>: 001e6000 load_application_info: Could not load signer identity from /private/var/mobile/Applications/1760C562-3886-4081-A4B2-FC2DA20D6B49/AppScaffold.app/AppScaffold
Feb 17 13:30:44 unknown lsd[344] <Notice>: MS:Notice: Installing: (null) [lsd] (675.00)
Feb 17 13:30:44 unknown SpringBoard[26] <Warning>: Reloading and rendering all application icons.
Feb 17 13:30:45 unknown sandboxd[349] <Notice>: MS:Notice: Installing: (null) [sandboxd] (675.00)
Feb 17 13:30:45 unknown com.apple.debugserver-64[348] <Warning>: debugserver-64 for armv6 Copyright (c) 2007-2009 Apple, Inc.  All Rights Reserved.
Feb 17 13:30:45 unknown com.apple.debugserver-64[348] <Warning>: Connecting to com.apple.debugserver service...
Feb 17 13:30:46 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.yourname.gamename[0x17e1]) Spawned and waiting for the debugger to attach before continuing...
Feb 17 13:30:46 unknown com.apple.debugserver-64[348] <Warning>: Got a connection, waiting for debugger instructions for task "(null)".
Feb 17 13:30:46 unknown kernel[0] <Debug>: lockbot[337] Builtin profile: debugserver (sandbox)
Feb 17 13:30:46 unknown kernel[0] <Debug>: launchd[351] Builtin profile: container (sandbox)
Feb 17 13:30:46 unknown kernel[0] <Debug>: launchd[351] Container: /private/var/mobile/Applications/1760C562-3886-4081-A4B2-FC2DA20D6B49 [69] (sandbox)

I have tried, in the past, just leaving it at the replace me screen, to see if it does eventually load.. but I got bored of waiting after 6 mins or so.

35
Ask a Question / Platform motion + Ride on platform (having problems)
« on: February 16, 2012, 06:02:57 am »
Hi.
Hopefully someone can help me out as to why I can't get these 2 things working together when the platform is moving horizontally.
I downloaded the pack from stencylforge that has the platform motion, ride on platform, and drop after time behaviours in.

Created a platform actor, stuck it in a group called platforms, and made it colide with my player.
Attached the platform motion behaviour to it, and set up 2 platforms, one moving left/right, and other moving up/down to test. Gave it some values...and awesome. It works really well.

I then added the ride on platform to my player. Chose the platform group in the drop-down etc and tried my scene again

On the up/down platform, it appears it works really well (as you don't get that "physics" where as the platform drops the player falls slightly afterwards)....I assume it is working fine there as I see a difference to when I didn't have that behaviour attached.

When the player is on the left/right moving platform however, it behaves exactly as it did before I attached the ride on platform to my player.
i.e. player stays stationary as the platform slides left and right under it

My player has a circle collision shape...so as a test, I changed that to square..but no difference there. Also messed around with the players heaviness and friction settings...but again, it seems the same.

Did I do something wrong? or am I missing something?

36
I had a similar prob last night.
I clicked the "change tile size button" right after importing but didn't change anything (left it as 32x32) clicked ok, and it magically fixed it.

37
Okay, I guess the round-block will return an integer in iOS. And the result of an integer division is again an integer.
Try this instead

awesome!  :)

Thankyou

38
You can do rounding like this in the screenshot:
"x" is the number you want to round down. It will be rounded to two decimal places, you can replace 100 with another power of 10 to round to a different number of decimal places, 1000 will round to 3 decimal places, 10000 to 4, and so on)

yay...coooool
Thanks for that. Magic.

--edit-- Although not in iOS... it just rounds to a whole number  :(

39
Is there an easy way to do this?
I have a "time" counter in my scene which counts up 1 per second, and I want to display is as e.g  1.35....

att he mo is displays as something like 1.3500032 (as an example)

Just wondering if there was an obvious way to limit the decimals to 2 that I am missing somewhere.

Cheers in advance for your help

Sparks.

40
Looks like quite a few people are getting fooled by the notion of typing in the group name directly. Even though this works in Flash, it's not the intent of the system - I'll make some changes to adjust this.

I should have taken my own advice.
My flatmate has also been playing around with Stencyl...and I keep telling him "typing bad....dragging good"

;)

41
cheers cole.

makes sense now, thanks for getting back to me.

42
Hmm.
I fixed it
Not sure why I was doing the behaviour like I was in my OP.
But this now works (doing it properly I assume....)  ;)

Still a bit of a noob at all this...got GameSalad rules hard-coded into my brain that I need to shed  :)

Is there any reason though that my original rule would work fine in flash but not in iOS?

43
I'm really not sure what I have done wrong here...but I am having real trouble figuring out a problem I have.

I have 2 actors in a scene. One in a collision group called players, and one in a group called exit

To simplify things, I have deactivated ALL my behaviours except 1, and removed everything except a "kill self" when it hits the other actor as shown in the attachement:

When I test in flash...actor 1 hits actor 2, and disappears....as expected
When I test in iOS (in the simulator, or on my device), actor 1 hits actor 2....and stays there.

Am I being really thick? As I have said, I have simplifies the rule about as much as is poss. I originally had it triggering a game attribue to true, and then had a scene behaviour doing stuff when that was true. So thought I had messed up somewhere with that. But this basically says, if 1 hits 2, kill 1 right??? And as stated, works as expected in flash.

(am running 1.4.1 btw)

Any ideas?

44
Game Art / Do you need music? Seasoned pro offering my services.
« on: February 02, 2012, 06:07:32 pm »
Hi there.

Just thought I would pop up a small message to le everyone here know that I am a musician, and can be hired to make music for your games.

I have sound-tracked a number of games (mainly iOS titles), and you can check out a few examples here :
http://soundcloud.com/markcoupe
(there are a couple of freebies on the soundcloud page too)  :)

I've everything written 60's surf rock to full on orchestral pirate themes, to 8bit chiptastic tunes.....and pretty much everything in-between

Drop me a line if you need music for your projects and we can discuss further.

Enjoy

Sparky.

45
Ask a Question / Re: 1 Scene VS several Scenes?
« on: February 02, 2012, 06:08:09 am »
Stencyl handles scenes in a slightly different way to GS

In GS, as you switch scenes you get a noticable "load"
With stencyl, you don't, and as pointed out by fotogeluid you can add a transition (fade etc) between them. There seems to be more of a load when the user initially starts the game as a trade off...but there is a progress bar, so it doesn't feel so bad.

This is all the same for iOS. If you are unsure, go buy a game called "Feed My Zombie", made in iStencyl and you will see how the scene switching looks.

Pages: 1 2 3 4