Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - candycornown

Pages: 1 2 3
31
Thank you all for your replies. I will test new things that you recommended. As for the code, I checked it and everything seems fine.

I will post the results later.

32
After thinking what could be wrong I deleted most of actors, I just left player and item at the end to pickup. FPS are around 60. Most of the time jumping from 56 to 58 and to 60.. And I also noticed FPS spikes that drop to 40 FPS even if I am standing and nothing is on the screen except tiles.

Does that mean that there is something wrong with code? I would also point out that there is constantly updated:

[LOG] I/trace   (19917): Design_4_4_Jumping.hx:101: 0

And sometimes between lines I get:

[ERR] java.lang.NullPointerException

Is that the cause of FPS drops?

33
Thank you for your reply.

I tried that and it didn't work. When I created that event it killed all coins in scene. I don't know why.  :)
I also checked Physics tab and choose Simple physics. FPS went up but I actors couldn't collide with each other...

I hope there is any other way, because without coins game looks kinda empty. If I have 10 coin actors FPS is at 60...

34
Hi,

Sorry for another topic. I have scenes with coins to collect in Stencyl. If I play it in browser or flash it works fine but when I play it on Moto G FPS drops to around 30. If I collect those coins my FPS increase.

I tried and deleted most coins just to see if that was the problem and it was.
Is there any way to create those coins when my character gets in that region.  Because I think that all coins in whole scene are created at the same time causing FPS drop.

If anyone has a solution please reply.

Thank you!

35
Ask a Question / Re: Lines between tiles? (mobile)
« on: August 08, 2014, 01:50:32 am »
I have exactly the same problem.  Only noticed it on Android phone, not on flash player.

36
Resolved Questions / Re: Anchor to screen causing FPS drops.
« on: August 05, 2014, 06:35:23 am »
Works now!

Thank you so much!  ;)

37
Resolved Questions / Anchor to screen causing FPS drops.
« on: August 05, 2014, 05:54:24 am »
Hello,

I have a problem with anchoring actors to screen. After some time (about 30 sec) in level FPS starts to fall. If I delete those actors the problem disappears.

For those actors I have set: Always - Anchor self to screen. And I have set that it cannot move.

I have also noticed that this problem occurs on Flash player and Android device not on browser.

Anyone have any idea what could be the problem?

Thank you

38
Resolved Questions / Re: Spinning Coin - Strange looping
« on: May 28, 2014, 07:13:11 am »
I just unchecked sync. and restarted Stencyl and now it works perfectly. :D

Ty!

39
Resolved Questions / Re: Spinning Coin - Strange looping
« on: May 28, 2014, 06:52:20 am »
Does it work correctly if your sync. box is not checked? Because I still have that problem if I uncheck it.

40
Resolved Questions / Re: Spinning Coin - Strange looping
« on: May 28, 2014, 06:11:56 am »
I re downloaded it and same problem. It is my first game that I have been working on for some time and I just found these coins to see how it works. I hope it's not the problem with Stencyl 3.1 that I download yesterday.

41
Resolved Questions / Re: Spinning Coin - Strange looping
« on: May 28, 2014, 06:05:32 am »
Just downloaded it and add it to the scene. In scene preview it works without any problem but when I test the game it looks like in that video.

42
Resolved Questions / Re: Spinning Coin - Strange looping
« on: May 28, 2014, 05:55:37 am »
Hi.

I didn't add any behavior to it. Which one should I add? Or do I need to create my own.

Ty

43
Resolved Questions / Spinning Coin - Strange looping
« on: May 28, 2014, 05:45:51 am »
Problem: the synchronized checkbox causes animations to restart too soon.

Hello.

I have a problem with Spinning Coin that I downloaded from the forge. Animations are already done and it is set to loop and sync. When I add it to the scene and play it it spins, but when I test the game it spins for 0.5 second and then it resets and do the same again.

Anyone know what can I do to spin it properly?

Thanks

Pages: 1 2 3