Bug Issue: Releasing android version for 4.3


Pages: 1

johnjanowskibsc

  • Level 1 Stencyler
June 23, 2018, 02:31:53 pm
Hi,

Am trying to test my game on android through playstore. I selected API 19 - 4.4, however when uploading the APK file to google it threw up this error

"You uploaded an APK with an invalid signature (learn more about signing). Error from apksigner: ERROR (Jar signer CERT.DSA): JAR signature META-INF/CERT.DSA uses digest algorithm SHA-256 and signature algorithm SHA-256 with DSA which is not supported on API Level(s) 19-20 for which this APK is being verified"

can I fix this error, if so can an update be issued through stencyl or is it Google?

thanks

John


Justin

  • Master Stencyler
  • *
June 29, 2018, 12:15:01 pm
Setting minimum api level to 21 should get you past this.

If we want to support lower minimum API levels, we might need to change how we do apk signing. This might be a good reference.

forums.gamesalad.com/discussion/95626/solution-you-uploaded-an-apk-with-an-invalid-signature-digest-algorithm-sha-256-signature-rsa

Looks like we might want to look at how we deal with certificate files as well.

http://community.stencyl.com/index.php?topic=56194.0


Issue updated by Justin - June 29, 2018, 12:20:28 pm
  • Tags added: 3.5 HP, android


Justin

  • Master Stencyler
  • *
June 29, 2018, 12:57:55 pm


Justin

  • Master Stencyler
  • *
August 09, 2018, 05:21:21 pm
I don't think this is a very important issue now given than Google won't be accepted games with a target version less than 26.
  • Tags removed: 3.5 HP


Pages: 1

Details

  • Reported
    June 23, 2018, 02:31:53 pm
  • Updated
    August 09, 2018, 05:21:21 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Updating Stencyl

Tags