Bug Issue: Text getting cut off at the top when using labels (iOS)


Pages: 1 2

JHKeller

  • Subscriber - Stencyl Studio
  • *
October 04, 2018, 11:55:54 pm
My text is getting cut off when using labels on iOS devices.

Happens with font I added as well as default stencyl fonts. Same fonts work fine when "drawing" text. Tested on iphone XS and iphone 6 plus in build 10019.



New attachment added by JHKeller - October 04, 2018, 11:56:11 pm


New attachment added by JHKeller - October 04, 2018, 11:56:16 pm


Issue updated by Justin - October 15, 2018, 08:56:47 pm
  • Tags added: 3.5 HP


Justin

  • Master Stencyler
  • *
October 15, 2018, 10:15:42 pm
Forum post. Probably affects all non-flash platforms.

http://community.stencyl.com/index.php/topic,57502.0.html


RulezTeam

  • Subscriber - Stencyl Studio
  • *
October 16, 2018, 01:13:55 am
I know that this issue is for label, but the problem is similar with my issue :

http://community.stencyl.com/index.php?issue=1175.0



rob1221

  • Master Stencyler
  • *
October 22, 2018, 07:34:26 am
I'm unable to reproduce the problem.  Do you have a sample project?
  • Status changed from New to Need Info


RulezTeam

  • Subscriber - Stencyl Studio
  • *
October 22, 2018, 02:34:04 pm
Hi rob,
is it possible that depend from font type ?
I've uploaded a font that have the same problem for my issue.


New attachment added by RulezTeam - October 22, 2018, 02:34:56 pm


Issue updated by rob1221 - October 22, 2018, 04:16:17 pm
  • Status changed from Need Info to Confirmed


New attachment added by JHKeller - October 22, 2018, 04:20:20 pm


JHKeller

  • Subscriber - Stencyl Studio
  • *
October 22, 2018, 04:21:41 pm
Attached an example scene, looks like it might be caused by using a "Do every x seconds" block to update the text in the label (at least in my case).

Thanks for looking into it!


rob1221

  • Master Stencyler
  • *
October 22, 2018, 04:34:17 pm
I was able to see the problem with the attached font, and I can also reproduce the disappearing font that Bombini reported.  Labels have been unchanged for a while though.

Update: Drawing the same text on the label actor shows the same cutoff problem so that part isn't even specific to labels.
« Last Edit: October 22, 2018, 04:50:32 pm by rob1221 »


rob1221

  • Master Stencyler
  • *
October 23, 2018, 06:14:54 am
@RulezTeam I'm seeing the cutoff issue in Flash and in Stencyl 3.4 so the problem is likely that your font is bad and you should find a new one.

I can see the cutoff problem in JHKeller's sample game, and if I enable word wrap I can also see the missing text problem.  I haven't found the cause yet and whether it's something to be fixed by OpenFL or not.
« Last Edit: October 23, 2018, 11:19:57 am by rob1221 »


Bombini

  • Subscriber - Stencyl Indie
  • *
October 24, 2018, 01:51:32 am
Is there something you need from me?
Can i be helpful?


rob1221

  • Master Stencyler
  • *
October 24, 2018, 11:18:52 am
The text cutoff is an OpenFL problem related to cacheAsBitmap being set to true.  Removing that part (line 117 in Label.hx) fixes the cutoff issue but I'm not sure what the consequence of that is.  I haven't narrowed down the word wrap disappearing text issue but that could also be on OpenFL's end.
  • Tags added: openfl


Bombini

  • Subscriber - Stencyl Indie
  • *
October 25, 2018, 12:38:06 am
word wrap:
I can confirm that the text is appearing again when i take the word wrap out.

line 117 in Label.hx
My labels.hx has only 108 lines. Might this be the issue? I dont find the line you are talking about.

One question:
The labels are very critical for the game im working on since a couple of years. I am getting a bit nervous. Is there a way to let someone know who could fix it if its an OpenFL problem?


rob1221

  • Master Stencyler
  • *
October 25, 2018, 04:51:08 am
Quote
line 117 in Label.hx
My labels.hx has only 108 lines. Might this be the issue? I dont find the line you are talking about.
Label.hx in the engine files, not Labels.hx the extension file.

Quote
One question:
The labels are very critical for the game im working on since a couple of years. I am getting a bit nervous. Is there a way to let someone know who could fix it if its an OpenFL problem?
I generally don't do anything with OpenFL including updating (Justin has been handling that).  I see we're a few weeks behind the latest, so maybe the next update will help.

Update: Word wrap might be fine when cacheAsBitmap is disabled because I only saw disappearing text when I was testing a long section of text larger than the text wrap width.  If Bombini confirms that line change fixes the text in his game then I'll just disable cacheAsBitmap for now.
« Last Edit: October 25, 2018, 06:26:46 am by rob1221 »


Bombini

  • Subscriber - Stencyl Indie
  • *
October 25, 2018, 08:04:34 am
I tested around one hour after taking out the lines:
Quote
#else
cacheAsBitmap = true;

Both problems, missing text and cut off text are gone.
I do have noise around the font characters though when i turn on fullscreen (not visible in the screenshot unfortunately).

      


New attachment added by Bombini - October 25, 2018, 08:05:02 am


rob1221

  • Master Stencyler
  • *
October 25, 2018, 08:57:11 am
Is that caused by turning cacheAsBitmap off or is that a separate issue?


Pages: 1 2

Details

  • Reported
    October 04, 2018, 11:55:54 pm
  • Updated
    November 11, 2018, 08:34:56 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Design Mode Blocks

Tags


Attachments

* log-2018-10-04.zip (1248.88 kB - downloaded 19 times.)

* Screen Shot 2018-10-04 at 11.43.48 PM.png (23.22 kB, 130x130 - viewed 153 times.)
* Regular.otf (26.85 kB - downloaded 19 times.)
* LabelTest.stencyl (982.85 kB - downloaded 23 times.)

* GoldSpace510 2018-10-25 16-36-38-44.bmp (6750.06 kB, 1920x1200 - viewed 35 times.)