Bug Issue: Find in Behaviours doesn't always work


Pages: 1 2

yoplalala

  • Subscriber - Stencyl Studio
  • *
January 16, 2016, 08:12:00 am
Update: the original issue seems to be fixed and the current issue is that the "find in behaviors" option (when right clicking on blocks) does not work for blocks that are detached from events.

I was looking for the attribute 1List  and it doesn't find it. It isn't the first that happens. ( it happens for two or three blocks in the scene, all the others works correctly like 10 List for example)

It's actually quite bothersome , as I like to delete unused attributes, and sudenly my scene doesn't work anymore.
« Last Edit: April 24, 2017, 07:36:31 am by rob1221 »


captaincomic

  • Master Stencyler
  • *
January 17, 2016, 02:26:22 pm
When you use Find in Behaviors on an attribute block, it would only show the current behavior. Is that what you want?

Anyway, it's strange that the current behavior is not showing up in the list.


yoplalala

  • Subscriber - Stencyl Studio
  • *
January 18, 2016, 01:00:35 am
Yes it's what I want for blue attributes :) .

-The thing I noticed , it's that it does that for blue and purple attributes, but like less than 10 % of the time. ( maybe even less  ...)
-It shows nothing at all  ( it doesn't show for example half of the 1List  and don't show the other half).
- I have also the error from time to time that when I rename an attribute, it doesn't rename the attributes ( and the scene doesn't work afterwards because he doesn't recognize the name of the variables). I think it must have the same origin

-


Issue updated by captaincomic - January 21, 2016, 01:39:14 pm
  • Status changed from New to Confirmed


captaincomic

  • Master Stencyler
  • *
January 26, 2016, 04:45:30 pm
I fixed a different issue, but I believe it may have had the same cause: http://community.stencyl.com/index.php/topic,46158.0.html

Please try if you still have this problem.
  • Status changed from Confirmed to Need Info


captaincomic

  • Master Stencyler
  • *
March 07, 2016, 03:58:28 pm
Apparently it's still happening.
Hi

Using build 9000.  When I right click on a 'game attribute setter' or 'getter' and click find in behaviours, it opens a list of behaviours but when I open one they are not highlighted in red and flashing.   Sometimes it works for a 'getter' but not always.
  • Status changed from Need Info to New


hairyfingers

  • Subscriber - Stencyl Studio
  • *
March 08, 2016, 02:12:47 am
Thanks for bringing my issue into this discussion. Can I help in anyway, happy to send you my stencyl game file if you need, to see what it's doing.
« Last Edit: March 08, 2016, 02:13:25 am by hairyfingers »


captaincomic

  • Master Stencyler
  • *
March 09, 2016, 02:55:51 am
Yes. It used to be like this: before you opened the attributes tab in the palette finding an attribute getter/setter didn't work. That bug was fixed. Now I don't know in which situation it still doesn't work. If you have a game and/or steps to reproduce the issue, that'd be great.


hairyfingers

  • Subscriber - Stencyl Studio
  • *
March 17, 2016, 01:54:44 pm
Hi

Sorry for the delay.

I've uploaded it to dropbox  here:

https://www.dropbox.com/s/sybchni9sl6e49a/OppicopCrossPlatform.stencyl?dl=0

sorry, it's pretty big as it's basically a completed game.  The issue seems to happen all over the place, not just with game attributes but other blocks too, no real reason to it - sometimes it works on some blocks but not on others.

cheers


captaincomic

  • Master Stencyler
  • *
March 18, 2016, 05:16:26 am
Thanks! I'll take a look.


hairyfingers

  • Subscriber - Stencyl Studio
  • *
March 23, 2016, 10:51:31 am
Any joy?


captaincomic

  • Master Stencyler
  • *
March 27, 2016, 01:18:34 pm
Yes, I see now (I just re-read your original report). Is it only the highlighting that is not working now, right? The list of behaviors is showing up correctly, but when you open a behavior from the list, the blocks and events are (sometimes) not highlighted.
  • Status changed from New to Assigned
  • Issue Assigned from (none) to captaincomic


captaincomic

  • Master Stencyler
  • *
March 27, 2016, 03:22:03 pm
Found the problem (and some others). Fixed in build 9068. Please test if everything works for you now.
  • Status changed from Assigned to Resolved


hairyfingers

  • Subscriber - Stencyl Studio
  • *
March 29, 2016, 03:41:12 pm
hey great!! all seems to work as it should  now.

good work


Issue updated by captaincomic - April 02, 2016, 05:47:28 am
  • Status changed from Resolved to Closed


yoplalala

  • Subscriber - Stencyl Studio
  • *
April 19, 2016, 09:05:26 am
In build 9074 , it doesn't find attributes when they are in blocks like "increment"


captaincomic

  • Master Stencyler
  • *
April 19, 2016, 06:20:03 pm
Is that a regression, or was it always like that?
  • Status changed from Closed to New


yoplalala

  • Subscriber - Stencyl Studio
  • *
April 22, 2016, 06:37:12 am
Honestly, I have no idea.

But I found this bug

see attached image ( valueOfGameAttribute)


I tried to look for the block " value of game attribute with name" , I opened the the proposed ressource  "PauseWindow" , but the event and the block weren' highlighted.
So I looked again  the block " value of game attribute with name", and it didn't propose me "PauseWindow" anymore even though there is still exists in the scene.

edit: the exact same thing happened multiple times, it happens only for blocks that are not attached
« Last Edit: April 22, 2016, 06:57:10 am by yoplalala »


New attachment added by yoplalala - April 22, 2016, 06:39:28 am


New attachment added by yoplalala - April 22, 2016, 06:43:23 am


Justin

  • Master Stencyler
  • *
April 22, 2016, 11:51:56 am
Blocks are searched for in two different ways: Using the behaviors xml data if it hasn't been opened and using the loaded Design Mode data if it has been opened. It sounds like there's a discrepancy between the two.


Pages: 1 2

Details

  • Reported
    January 16, 2016, 08:12:00 am
  • Updated
    April 24, 2017, 01:21:55 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Confirmed
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    (none)

Tags


Attachments


* valueOfGameAttribute.png (5.54 kB, 1600x900 - viewed 105 times.)

* valueOfGameAttributeSearch (95.99 kB, 1592x757 - viewed 118 times.)