Bug Issue: (After upgrading a game from using 8627 to 8670 , however creating a fresh new game using 8670 doesn't encounter this bug) A event which changes a default value of a Game Attribute will only happen once.


Pages: 1

Donni11

  • Subscriber - Stencyl Indie
  • *
September 20, 2015, 05:15:13 pm
Note : This bug is only encountered after upgrading a game from using 8627 to 8670 , however creating a fresh new game using 8670 doesn't encounter this bug.

Hello Stencyler :) ! A event which changes a default value of a Game Attribute will only happen once.. I only started received this problem in the Build 8671. Logs attached on the side -

Screenshot of what I mean :
« Last Edit: October 16, 2015, 01:40:21 pm by Donni11 »


New attachment added by Donni11 - September 20, 2015, 05:16:55 pm


captaincomic

  • Master Stencyler
  • *
September 24, 2015, 08:43:24 pm
What kind of event are you referring to? Could you provide a test game?
  • Status changed from New to Need Info


Donni11

  • Subscriber - Stencyl Indie
  • *
September 25, 2015, 09:48:46 am
I can't provide a test game because I'm working on a game with someone and I don't think he wants the game file posted publicly. But here is a screenshot of the code that is only happening once (it happens with any code I think) :
« Last Edit: September 30, 2015, 06:21:26 pm by Donni11 »


Donni11

  • Subscriber - Stencyl Indie
  • *
September 25, 2015, 11:05:39 am
Also I found out that when you pause the game and unpause it starts to work again.


captaincomic

  • Master Stencyler
  • *
September 28, 2015, 04:11:16 pm
Okay, no need to share the full game, just a simple project with the event that is only happening once would do. I cannot see your screenshot btw.


Issue updated by Donni11 - September 30, 2015, 05:10:49 pm
  • Issue renamed from "When Event Is Placed In scene it happens the first time but not the 2nd.." to "Do every [] second block doesn't happen anymore after a reload."


New attachment added by Donni11 - September 30, 2015, 06:09:31 pm


Donni11

  • Subscriber - Stencyl Indie
  • *
September 30, 2015, 06:12:19 pm
Repost :

Hello Stencyler :) ! A event which changes a default value of a Game Attribute will only happen once.. I only started received this problem in the Build 8671. Logs attached on the side -

Screenshot of what I mean :
  • Issue renamed from "Do every [] second block doesn't happen anymore after a reload." to "A event which changes a default value of a Game Attribute will only happen once."


Donni11

  • Subscriber - Stencyl Indie
  • *
« Last Edit: October 07, 2015, 12:27:52 pm by Donni11 »


Issue updated by Donni11 - October 15, 2015, 04:21:06 pm
  • Category changed from Design Mode to Game Attributes


oripessach

  • Subscriber - Stencyl Studio
  • *
October 15, 2015, 05:23:49 pm
Donni, these problems seem completely unrelated.

I got curious about this issue and tried to reproduce it. I can't seem to do that, though. I'm attaching the game I've used to try to reproduce the bug. If you run it, you'll see the the game attribute's value increments once a second.


New attachment added by oripessach - October 15, 2015, 05:24:35 pm


Donni11

  • Subscriber - Stencyl Indie
  • *
October 16, 2015, 01:33:10 pm
Yes , I noticed that by working on a test game, to be more specif :
  • Issue renamed from "A event which changes a default value of a Game Attribute will only happen once." to "(After upgrading a game from using 8627 to 8670 , however creating a fresh new game using 8670 doesn't encounter this bug) A event which changes a default value of a Game Attribute will only happen once."


Issue updated by Donni11 - October 16, 2015, 01:44:51 pm
  • Category changed from Game Attributes to Updating Stencyl


oripessach

  • Subscriber - Stencyl Studio
  • *
October 16, 2015, 01:51:59 pm
Did you try putting a print block in your event and verify that it doesn't run?


captaincomic

  • Master Stencyler
  • *
November 02, 2015, 09:10:53 am
I assume this was a problem in your game, but it's hard to tell. I don't think we can reproduce or fix this without test game.
  • Status changed from Need Info to Closed


Pages: 1

Details

  • Reported
    September 20, 2015, 05:15:13 pm
  • Updated
    November 02, 2015, 09:10:53 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    3.3.2
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Updating Stencyl

Tags


Attachments

* log-2015-09-20 -again,.zip (294.33 kB - downloaded 149 times.)

* SceneEvents_3.png (2.72 kB, 751x72 - viewed 422 times.)
* Game Attribute Test.stencyl (282.92 kB - downloaded 167 times.)