Bug Issue: Odd tile collision problem


Pages: 1

suitcasenuke

  • Subscriber - Stencyl Studio
  • *
March 10, 2018, 03:36:27 am
I'm not even sure how to categorize this strange thing. I've attached a gif of what's happening. It seems like collisions between the player and tiles is off somehow. The puff of smoke is only supposed to appear when the player hits the ground after a jump. But it's as though not all tiles are treated the same way. I can move around and the problem disappears. Also, just changing the tile layout (in this case just moving the tile wall one tile to the left) solved the problem.
« Last Edit: March 10, 2018, 03:37:22 am by suitcasenuke »


New attachment added by suitcasenuke - March 10, 2018, 03:36:56 am


rob1221

  • Master Stencyler
  • *
March 22, 2018, 07:29:06 pm
Do you happen to also have a sensor collision shape on that actor?


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
March 23, 2018, 02:18:19 am
Nope, just one solid shape. I don't know if this is related, but this seems to only occur within the first 10-20 tiles of a scene.


Justin

  • Master Stencyler
  • *
March 23, 2018, 11:25:41 pm
Have you enabled debug drawing to see if the tile collisions look differently than expected?
  • Status changed from New to Need Info


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
March 24, 2018, 02:21:58 am
I just quickly created a fresh scene and attached the results with debug drawing on. Very odd.


New attachment added by suitcasenuke - March 24, 2018, 02:22:28 am


rob1221

  • Master Stencyler
  • *
March 25, 2018, 07:48:30 am
Can you attach a sample game showing the problem?


rob1221

  • Master Stencyler
  • *
March 25, 2018, 12:04:24 pm
What's happening here is that certain layouts of tiles is causing your actor's Y speed to be very slightly below 0 (as an example, 5.55111512312578e-17).  I'm still trying to narrow down why this is happening, and maybe it's a quirk with box2D, but for now you can adjust your code to check for y speed < 0.01 instead of 0.
  • Status changed from Need Info to Confirmed


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
March 25, 2018, 12:48:55 pm
Thanks! That's an odd one.


Pages: 1

Details

  • Reported
    March 10, 2018, 03:36:27 am
  • Updated
    March 25, 2018, 12:48:55 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Confirmed
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Collision Groups

Tags


Attachments


* tiles.gif (1986 kB, 456x312 - viewed 25 times.)

* Mar-24-2018 05-20-04.gif (5993.64 kB, 640x474 - viewed 23 times.)