Bug Issue: Odd jitter on actors


Pages: 1

suitcasenuke

  • Subscriber - Stencyl Studio
  • *
May 05, 2018, 10:58:33 am
I've noticed something odd on the build using the new OpenFL/Lime combo (9874). It seems like actors and tiles don't obey the same grid when the camera is moving, if that makes sense. I don't think this issue was present before the change? Or if it was before, I guess it wasn't this pronounced? Having pixel snapping on or off doesn't have any effect. See attached video for reference! The spikes and tiles don't 'match' so to speak.

Thanks
« Last Edit: May 05, 2018, 10:59:56 am by suitcasenuke »


New attachment added by suitcasenuke - May 05, 2018, 11:00:27 am


rob1221

  • Master Stencyler
  • *
May 08, 2018, 11:06:28 am
I'm unable to reproduce this issue so I'll need to see a sample game showing the problem.
  • Status changed from New to Need Info


rob1221

  • Master Stencyler
  • *
May 08, 2018, 12:59:36 pm
Even with a sample game I can't reproduce this issue and I've tried testing Flash/HTML5/Windows in windowed and full screen mode.  Perhaps the issue only happens with particular scaling settings or maybe it only happens on iOS.
  • Status changed from Need Info to New


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
June 03, 2018, 11:10:10 am
Hmm, the only other information I can offer is that I'm using Scale to Fit (Full Screen) and publishing on iOS, and the camera follows a player actor. This also occurs on an old game I'm trying to update, under the same conditions.

It is slightly less noticeable on the older game though, as the screen size is larger at 480x320.


AlexVsCoding

  • Subscriber - Stencyl Studio
  • *
June 11, 2018, 03:58:42 am
I can second this problem, I've been experiencing a stepped jitter to the movement of my tiles in game, game works fine on all other platforms other than iOS. I can work around it for Baboom, but when it comes to updating Narcissus for iPhone X, this will be a game breaking bug.


Issue updated by Justin - June 29, 2018, 12:41:05 pm
  • Tags added: 3.5 NP, graphics


suitcasenuke

  • Subscriber - Stencyl Studio
  • *
October 09, 2018, 08:01:14 am
I'd just like to report that this is no longer apparent or noticeable (at least to my eyes) anymore! Currently using build 10023.


Issue updated by rob1221 - October 09, 2018, 09:01:15 am
  • Status changed from New to Resolved
  • Tags removed: 3.5 NP


Pages: 1

Details

  • Reported
    May 05, 2018, 10:58:33 am
  • Updated
    October 09, 2018, 09:01:15 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Engine

Tags


Attachments

* 720p.MOV (1617.61 kB - downloaded 25 times.)