Bug Issue: Memory, lag, and crash for game with connection active


Pages: 1

RulezTeam

  • Subscriber - Stencyl Studio
  • *
July 25, 2018, 05:24:31 am
Hi,
I'm porting some games to 3.5 and I cannot play it because there are too much problems.
 
One big problem is when the game is connected to internet. There isn't any difference from debug version or publish version, because I have the same result. When you play it the game start with artificial graphics artifact (the screen is partial redraw with black block) and then all the screen became black. The game is responding (touch) so you can exit from a level to return in menu scene (and the screen return to show itself correctly) , but I cannot play it.
I've attached some screen of FPS monitor, and we can see how the use of memory is big (the game should be a footprint of about 50Mb), and then the FPS go down so much that the game lag.
If I block the connection (wifi of mobile data), everything goes well.

With 3.4 no problem at all,  with or without connection active.

Why are there so much problems with this new 3.5 version ?
« Last Edit: July 25, 2018, 05:29:59 am by RulezTeam »


New attachment added by RulezTeam - July 25, 2018, 05:25:11 am


New attachment added by RulezTeam - July 25, 2018, 05:25:21 am


Issue updated by RulezTeam - July 25, 2018, 05:29:59 am
  • Issue renamed from "Memory, lag, and crash for game with connection" to "Memory, lag, and crash for game with connection active"


RulezTeam

  • Subscriber - Stencyl Studio
  • *
July 25, 2018, 05:32:27 am
I forgot to write that I've tested it with Android (different version) and build 9928
« Last Edit: July 25, 2018, 05:34:00 am by RulezTeam »


RulezTeam

  • Subscriber - Stencyl Studio
  • *
July 25, 2018, 06:45:25 am
Update

I hope that this can help to investigate: the game that I've tested make use of :

- move camera center to actor (always follow actor in the scene)
- scene width are little big (about 670 tiles / 6000 pixel)

Anyway the problem comes out on alternate levels (levels 1 ok, levels 2 memory, lag and crash) and always if the connection is active.


Finally I repeat, with 9328 (3.4 version) no problems at all.
« Last Edit: July 25, 2018, 06:46:43 am by RulezTeam »


RulezTeam

  • Subscriber - Stencyl Studio
  • *
July 30, 2018, 02:34:38 am
Hi,
in this game I use tiles, but I don't understand because the problems are coming only when I have a connection.
So, I don't think that it's some important that my scene is big, or I use tile or move camera... but it seems that there are still problems with tools/hud or other similar issue reported by me and other users in the past. (for example slow loading when connected, etc.)

Can someone looking at this strange problem ?

Thank you


RulezTeam

  • Subscriber - Stencyl Studio
  • *
August 10, 2018, 01:10:28 am
Hi,
I've read that some other similar issue are been closed in these days with :" hoping for future third party library updates".
So, is this my case too ? In my game there are multiple actors on the scene, so is this the problem ? But why only when connection is active ?

Since 3.5, the performance issue has been a BIG problem on Stencyl. And now after almost two years of development there are still problems.

However, now I cannot understand, why the big problems are specifically with connection active. As I reported, in the last months,  several problems have been linked to connection.

Now I would like to know, if these issues can been resolve, and in a short time, because I cannot publish my game since Apple request iPhoneX compatibility, Google ask for api 26 targeting and with Stencyl 3.4 there aren't these possibilities. Moreover, there is the other big problem of GDPR for publish in Europe.

Thank you.
« Last Edit: August 10, 2018, 01:13:55 am by RulezTeam »


Justin

  • Master Stencyler
  • *
August 10, 2018, 01:49:27 am
Pretty much everything you've brought up is nearly impossible to look at without a sample game. I haven't experienced any of these issues, so it's likely some specific combination of factors within your specific game.

I'll need to see your game to have any hope of making sense of this in a reasonable timeframe, as well as steps you take in the game in order to see the issues you've encountered.

You mentioned something about black boxes, which some other users have mentioned as well. For that, Dincicode said that he'll make a sample game for me tomorrow.

AdMob/GDPR is one of the few remaining high-priority items for 3.5, so we'll be working on that again soon. If you're in a rush, though, there's the possibility of other ad networks, such as Unity. I can pass you along to somebody who has a Unity Ads extension, which is supposedly GDPR compliant without you having to do anything.


RulezTeam

  • Subscriber - Stencyl Studio
  • *
August 13, 2018, 06:24:27 am
Hi Justin,
where can I send you the project ?


Justin

  • Master Stencyler
  • *
August 14, 2018, 07:29:51 am
You can PM me a link to it.


RulezTeam

  • Subscriber - Stencyl Studio
  • *
August 17, 2018, 05:42:57 am
Hi Justin,
I've sent you a PM. Did you have received ?


Justin

  • Master Stencyler
  • *
August 17, 2018, 11:57:55 pm
I did receive it. Just tried opening it, and I'm missing a few of the extensions. I'll send you a PM with the details.


Issue updated by Justin - August 20, 2018, 01:59:55 am
  • Tags added: 3.5 HP


RulezTeam

  • Subscriber - Stencyl Studio
  • *
August 22, 2018, 08:24:56 am
Hi Justin,
have you something news for me ?
Is this a problem about the use of tiles as another user as reported here : http://community.stencyl.com/index.php/topic,57202.0.html   ?


Pages: 1

Details

  • Reported
    July 25, 2018, 05:24:31 am
  • Updated
    September 15, 2018, 10:13:51 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Engine

Tags


Attachments


* WithConnection.png (2.5 kB, 89x119 - viewed 165 times.)

* WithConnection2.png (2.74 kB, 114x106 - viewed 169 times.)