Bug Issue: "Stop all sound" block crashes or freezes game on windows, android and ios10


Pages: 1

FMStudioGameDev

  • Subscriber - Stencyl Studio
  • *
August 23, 2018, 02:07:22 am
As title says I am experiencing random crashes and/or game freezes when entering a scene and stopping all sounds (it seems that there's no issue if no sound is playing even if the block is in the scene).
If removing the block no crash/freeze happens.

Logs  don't show any error on windows and android, on ios I got this:
Code: [Select]
[ios-deploy] Process 6606 stopped
[ios-deploy] libc++abi.dylib: terminating with unexpected exception of type std::bad_alloc: std::bad_alloc

It looks like the bug does not occur on Mac and on devices running ios11+
« Last Edit: August 23, 2018, 02:08:37 am by FMStudioGameDev »


FMStudioGameDev

  • Subscriber - Stencyl Studio
  • *
September 05, 2018, 02:36:50 am
Attaching full logs. Hope somebody wants to look inside this bug because it prevents from having  different musics.
I can also attach a sample game showing the issue is needed.
« Last Edit: September 05, 2018, 02:37:42 am by FMStudioGameDev »


New attachment added by FMStudioGameDev - September 05, 2018, 02:37:04 am


FMStudioGameDev

  • Subscriber - Stencyl Studio
  • *
September 06, 2018, 02:32:23 am
I have attached a sample game.
To reproduce the issue simply stay on the first scene for a bit (let the track loop a couple of time) and then tap to change scene.
  • Crashes almost always on iOS 10 with bad_alloc error reported above.
  • Sometimes just freezes, sometimes crashes on an Android device running Lollipop (5.1)
  • Crashes almost always on Android emulator (Bluestack)
  • Crashes randomly on windows
  • No issues on Mac


New attachment added by FMStudioGameDev - September 06, 2018, 02:32:55 am


Issue updated by Justin - September 18, 2018, 03:20:33 pm
  • Tags added: openal


Justin

  • Master Stencyler
  • *
September 21, 2018, 04:42:56 am
Could you try with b9991?


FMStudioGameDev

  • Subscriber - Stencyl Studio
  • *
September 21, 2018, 07:40:46 am
Could you try with b9991?
It seems to be fixed for iOS 10 and Android (even if I have a black screen on BlueStacks emulator, but it works on device).
Didn't have the chance to test on windows yet .


Justin

  • Master Stencyler
  • *
September 21, 2018, 08:41:12 am
Windows was where I was testing primarily, and I wasn't able to hit it again after the change I made, so I'll consider this fixed. Thanks.
  • Status changed from New to Resolved
  • Issue Assigned from (none) to Justin


Pages: 1

Details

  • Reported
    August 23, 2018, 02:07:22 am
  • Updated
    September 21, 2018, 08:41:12 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Engine

Tags


Attachments

* log-2018-09-05.zip (566.28 kB - downloaded 29 times.)
* testGameSound.stencyl (2075.94 kB - downloaded 30 times.)