Bug Issue: Atlases seem to slow down game substantially now in recent builds.


Pages: 1

AlexVsCoding

  • Subscriber - Stencyl Studio
  • *
October 01, 2018, 07:09:22 am
Hey! I'm currently going through the process of updating my app corporate Salmon and I've noticed some substantial differences in the performance of the game, in particular the loading time between scenes. In earlier versions of the game, the atlas system sped up loading (Necessary because the high use of audio in the game), but for some reason a year on in the build I'm using (9982) transitions now take 1-2 seconds (Instead of .5) and experiences lag. I've attached comparative footage of the two versions to hopefully make this clear the difference.

Check out the comparative footage here: https://youtu.be/lnYCRBCv_qg

This is not an isolated incident either: I actually opted to remove atlases from my latest game, SHUMP after it added 2 seconds of loading time onto the menu to gameplay transition (When I actually expected the opposite to happen). Switching the atlases off restored it to normal speed. I'm currently on build 9982, let me know if this is something that has been fixed in most recent version!
« Last Edit: October 01, 2018, 07:12:07 am by AlexVsCoding »


Issue updated by Justin - October 15, 2018, 08:57:31 pm
  • Tags added: 3.5 HP


rob1221

  • Master Stencyler
  • *
January 18, 2019, 10:05:46 am
With the recent audio changes, is this still an issue?
  • Status changed from New to Need Info


Pages: 1

Details

  • Reported
    October 01, 2018, 07:09:22 am
  • Updated
    January 18, 2019, 10:05:46 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Need Info
  • Priority
    Normal
  • Version
    Stencyl 3.5
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Atlases

Tags