Bug Issue: Music in build 10046 is currently failing to play connected audio tracks URGENT


Pages: 1

AlexVsCoding

  • Subscriber - Stencyl Studio
  • *
October 29, 2018, 05:54:26 pm
Hey,

Previously I was having issues with focus being lost and the music I had in my iOS games was not restarting.

The latest version of Stencyl fixed that (10046), but it also appears to have broken the music function. Here are two major things that have changed:
1. Music continues from the place it was, rather than from the start (unless explicitly told to go to position 0)
2. Looping music stops after a while and changing back to a scene once looping music has started means other tracks in that scene refuse to play.

My current setup is this:

Menu
intro menu music
loop menu music

Gameplay
intro gameplay music
loop gameplay music

Shop
Intro shop music
Loop shop music
intro gameplay music (short)

When I transition to the various scenes, the intro music plays fine (and goes back to the start and I can easily alternate between the scenes and their respective music plays.

If however the music (via a "If channel finishes playing" block) switches to play the loop track, returning to this scene results in silence from the music channel.

If you could let me know ASAP whether this is a known issue with this build (And has been fixed in the latest one) or whether you need more info, I'd appreciate the suggestions. I'm midway through a feature and there's key things I need to update but this issue is stopping me from releasing my update.

Thanks for any help you can provide!
« Last Edit: October 29, 2018, 05:54:50 pm by AlexVsCoding »


Issue updated by AlexVsCoding - October 29, 2018, 05:54:50 pm
  • Issue renamed from "Music in build 10046 is currently failing to play connected audio tracks " to "Music in build 10046 is currently failing to play connected audio tracks URGENT"


AlexVsCoding

  • Subscriber - Stencyl Studio
  • *
October 30, 2018, 12:54:38 pm
Here's the issue in video format! Note that after the intro track hits the loop (at 0:39) when the scene is re-entered, the music no longer plays.

https://www.youtube.com/watch?v=2w5GA417_DA


Justin

  • Master Stencyler
  • *
October 30, 2018, 10:23:26 pm
We've received another report about issues with sounds, but no sample game so it's hard to fix.

http://community.stencyl.com/index.php?issue=1366.0


ChristianEs

  • Subscriber - Stencyl Studio
  • *
October 30, 2018, 11:10:27 pm
Please Alex send your .stencyl game to Justin, i sent mine before on a pm so he can fix these annoying music problems.
« Last Edit: October 30, 2018, 11:11:10 pm by ChristianEs »


Issue updated by Justin - November 11, 2018, 06:34:43 am
  • Tags added: audio


Justin

  • Master Stencyler
  • *
December 17, 2018, 11:40:23 pm
Audio issues should be better now with b10155.
  • Issue Assigned from (none) to Justin
  • Status changed from New to Resolved


Pages: 1

Details

  • Reported
    October 29, 2018, 05:54:26 pm
  • Updated
    December 17, 2018, 11:40:23 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    Stencyl 3.5
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Sound Editor

Tags