Bug Issue: Error on test iOS simulator iPhone Xs MAX


Pages: 1

rodolfovs

  • Subscriber - Stencyl Studio
  • *
February 04, 2019, 06:54:29 am
Hello,

I upgraded xCode to version 10.1 to be able to test the app on iPhone Xs Max (iOS Simulator), but the following error occurs:
Code: [Select]
[ios-sim] Device type "com.apple.CoreSimulator.SimDeviceType.iPhone-Xs-Max" could not be found.
I already tested clean the project, I already downloaded several iOS but it does not work. How can I solve this? I would test on the Iphone Xs Max to get the screenshots in the correct size.


Issue updated by Justin - February 04, 2019, 02:19:59 pm
  • Issue Assigned from (none) to Justin


irock

  • Master Stencyler
  • *
February 08, 2019, 09:21:42 pm
I'm having this same issue with several iOS simulator targets. Many of them work, but some don't. I went ahead and tested all of them and marked the ones that return the "device type _ could not be found" error.

iPad (5th generation) (9.7")
iPad (6th generation) (9.7")
iPad Air (9.7")
iPad Air 2 (9.7")
iPad Pro (9.7-inch) (9.7")
iPad Pro (10.5-inch) (10.5")
iPad Pro (11-inch) (11.0")

[X] iPad Pro (12.9-inch) (12.9")
iPad Pro (12.9-inch) (2nd generation) (12.9")
iPad Pro (12.9-inch) (3rd generation) (12.9")
iPhone 5s (4.0")
iPhone 6 (4.7")
iPhone 6 Plus (5.5")
iPhone 6s (4.7")
iPhone 6s Plus (5.5")
iPhone 7 (4.7")
iPhone 7 Plus (5.5")
iPhone 8 (4.7")
iPhone 8 Plus (5.5")
iPhone SE (4.0")
iPhone X (5.9")

[X] iPhone Xs (5.9")
[X] iPhone Xs Max (6.5")
[X] iPhone Xr (6.1")


rodolfovs

  • Subscriber - Stencyl Studio
  • *
February 11, 2019, 10:07:58 am
For me too, exactly those same devices I can not test in iOS simulator.


Justin

  • Master Stencyler
  • *
February 14, 2019, 07:31:50 pm
This should be fixed in b10279. Please test.


irock

  • Master Stencyler
  • *
February 15, 2019, 06:37:17 pm
Seems to be fixed. Tested the devices that didn't work before as well as the iPhone 5s.
« Last Edit: February 15, 2019, 06:39:25 pm by irock »


Issue updated by Justin - February 15, 2019, 07:16:12 pm
  • Status changed from New to Resolved


rodolfovs

  • Subscriber - Stencyl Studio
  • *
February 16, 2019, 04:12:41 am
I just tested and it works, thank you.


Pages: 1

Details

  • Reported
    February 04, 2019, 06:54:29 am
  • Updated
    February 16, 2019, 04:12:41 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Compiling/Testing Games

Tags