Bug Issue: Cannot test on Android phone (in 10311)


Pages: 1

grovian

  • Junior Stencyler
March 10, 2019, 10:29:11 am
Hi Guys,

I get error while compiling for Android. It seems to be somewhat connected to Admob, but I have no idea what to do.

Please find the log attached.

Thanks,
   Peter


New attachment added by grovian - March 10, 2019, 10:29:35 am


rob1221

  • Master Stencyler
  • *
March 10, 2019, 11:14:19 am
If you're using the old AdMob extension you should disable that and use the core Stencyl ad blocks.  Also make sure your minimum Android version is at least 14 and your target version is at least 26.
  • Status changed from New to Need Info


grovian

  • Junior Stencyler
March 11, 2019, 05:49:18 am
Hi Rob,

Thanks, but  I don't get your comments.
1. I don't use any extensions and this error occurs even if I turn admob off in the settings

2.  Android minimum version can be set to 28 but target can be only set to 16 or 19. How can I set this to higher (see Android_version.JPG)?

3. The first of many error messages is this. Do I have to download something?
[haxelib.exe] C:\Projects\Stencyl\stencylworks\android-builds\SpaceBattle5\admob\intermediates\res\merged\release\values-ldltr-v21\values-ldltr-v21.xml:3: AAPT: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Spinner.Underlined'.

I've deleted every admod related block and no change.

Thanks,
   Peter
« Last Edit: March 11, 2019, 06:26:29 am by grovian »


New attachment added by grovian - March 11, 2019, 05:49:31 am


New attachment added by grovian - March 11, 2019, 05:49:31 am


rob1221

  • Master Stencyler
  • *
March 11, 2019, 07:52:47 am
Go to File > Preferences > Tools > Download Android Tools.  After doing that then there should be a new target available (probably 28).  Your errors are caused by using an Android tools version that is too high for your current target version.


grovian

  • Junior Stencyler
March 12, 2019, 09:11:59 am
Thanks that worked (I can now set API 28).
But now it seems I have a java related error.
Please check java_error.jpg and java.jpg. Also I've attached new logs (log-2019-03-13.zip)


New attachment added by grovian - March 12, 2019, 09:12:17 am


New attachment added by grovian - March 12, 2019, 09:12:28 am


New attachment added by grovian - March 12, 2019, 09:12:35 am


New attachment added by grovian - March 12, 2019, 09:12:42 am


rob1221

  • Master Stencyler
  • *
March 12, 2019, 09:21:21 am
The only cause of that new error I have seen so far is installing Stencyl over an existing install.  If that is the case you need to reinstall Stencyl either in a new location or in the current location after deleting the current install.


grovian

  • Junior Stencyler
March 14, 2019, 10:10:43 am
After uninstall and reinstall it works indeed!

Thank you so much!


Issue updated by rob1221 - March 14, 2019, 10:52:27 am
  • Status changed from Need Info to Closed


Pages: 1

Details

  • Reported
    March 10, 2019, 10:29:11 am
  • Updated
    March 14, 2019, 10:52:27 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    Stencyl 3.5, 3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Compiling/Testing Games

Tags


Attachments

* log-2019-03-11.zip (190.99 kB - downloaded 22 times.)

* Android_version.JPG (18.35 kB, 483x138 - viewed 45 times.)

* Android_version.JPG (18.35 kB, 483x138 - viewed 46 times.)
* log-2019-03-13.zip (245.32 kB - downloaded 21 times.)

* Android_version2.JPG (17.28 kB, 440x118 - viewed 42 times.)

* Java.JPG (37.16 kB, 704x287 - viewed 45 times.)

* Java_error.JPG (143.08 kB, 1896x274 - viewed 44 times.)