Bug Issue: Behavior stops working (Problem Found)


Pages: 1

LtVax27

  • Subscriber - Stencyl Indie
  • *
June 16, 2019, 05:56:45 am
[Answer on my 3rd post]
Been working on 2 procedural codes, got them working fine then realized I had to store some data so I can spawn the same maps when needed. After adding all this I tried testing it only to have it not let me place the Actor at the end.

Upon looking at my print logs I noticed it was not printing for Clicks or button presses, at 1st I thought it might be disabled some how,  I  checked if any of the [State] Behaviors where in but nothing showed up,  added a [Draw if Behavior is not disabled] to the scene and that drew. I even copied it all over to a new Behavior but still no prints...   There are no Bools stopping it from printing either.

Now I'm not sure what to do...
I do have a few Custom Events and the final preview line is 3646 but I doubt that's the problem, unless there is a limit on something.
(All Keyboard and Click have prints for debugging)
« Last Edit: July 16, 2019, 12:32:16 pm by LtVax27 »


LtVax27

  • Subscriber - Stencyl Indie
  • *
June 16, 2019, 09:01:10 pm
I can upload my game files to Mega if needed (32mb) (Removed scaling, now 9.8mb) and message a link. While I do have a few other games I've been slowly building up I would like to get back into this one as I have been enjoying the challenge of procedural generation.
« Last Edit: June 18, 2019, 08:28:28 am by LtVax27 »


LtVax27

  • Subscriber - Stencyl Indie
  • *
June 17, 2019, 10:48:19 pm
Upgraded to 4.0.1, had to change some layer ID's to names and a number inc was not working after a [repeat __ times] (just poped it up and added a -1 to the 3D list) but it's still ?disabling? the click and buttons (still not printing or doing there function)

Bit more playing around and I've discovered that SceneEvent clicks and Actor Behavior Clicks work but won't trigger Custom Events in the MapGen behavior. It's like the Behavior just dies after generating the map and saving data to lists.

Set Stencyl up to run x64 in case that 90% warning I get now and then may have had some thing to do with this bug, no change.
Since it dose complete the generation before it stops working I tried adding some new types of objects to spawn to one of the events, had no problems running it but still but is still ?disabling? itself at the end. Have also moved the click/button events to a new Scene Behavior so I can keep working on it.

It was all the [Prints] fault (had so many), after getting it all working I went through and removed all my [Print] blox to see if I could get my loading overlay (Draw Black screen + Spinning arrow actor) to run a bit smoother and discovered the Behavior was not being disabled  :D
« Last Edit: June 25, 2019, 05:40:15 am by LtVax27 »


Issue updated by LtVax27 - June 25, 2019, 05:40:15 am
  • Issue renamed from "Behavior stops working" to "Behavior stops working (Problem Found)"


Justin

  • Master Stencyler
  • *
June 27, 2019, 05:15:46 pm
Would you like to pursue this bug? If you can get it to reproduce the issue of the print statements somehow disabling the behavior, and send me the game, I can look into this.
  • Status changed from New to Need Info


LtVax27

  • Subscriber - Stencyl Indie
  • *
July 16, 2019, 12:31:54 pm
Sorry, I have since removed all the Print Statements as the code was working at this point. I believe it was caused from printing a 3D list containing each change as my map generated. It was a lot of data and it would still be printing 10-20 secs after the map had generated. I can try to get it to do it again at some point and send you the file if your interested in it. (My 1st attempt at Map Generation using brute force so I had to print a tone to find all the bugs)


Pages: 1

Details

  • Reported
    June 16, 2019, 05:56:45 am
  • Updated
    July 16, 2019, 12:31:54 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Need Info
  • Priority
    Normal
  • Version
    3.4.0 beta4
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Behavior Settings

Tags