Bug Issue: Unable to build for Android


Pages: 1

Guzzz

  • Subscriber - Stencyl Studio
  • *
September 29, 2019, 05:50:43 am
Stencyl failed to build for Android. Among some of the errors Stencyl gave me this
Quote
[haxelib] Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Here are a bit more details on the issue
http://community.stencyl.com/index.php/topic,59148.0.html
I have android-ndk-r15c and Java jdk1.8.0_181.jdk.
Android minimum version while testing is 9-2.3 Gingerbread and Target is 24-7.0 Nougat.
On iOs and Flash everything works great!


Justin

  • Master Stencyler
  • *
October 06, 2019, 11:26:25 pm
The issue here was the android versions. Minimum had to be 14 or greater. Not sure about target, but it was set to 28 and it worked.


Justin

  • Master Stencyler
  • *
November 13, 2019, 07:55:23 pm
I've made Stencyl more strict about what you're allowed to use as version numbers for android in b10454.
  • Issue Assigned from (none) to Justin
  • Status changed from New to Resolved


Pages: 1

Details

  • Reported
    September 29, 2019, 05:50:43 am
  • Updated
    November 13, 2019, 07:55:23 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    Stencyl 3.4
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Compiling/Testing Games

Tags